Bug 152625 - the apache group is missing
the apache group is missing
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-03-30 15:32 EST by Florin Andrei
Modified: 2014-01-21 17:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 07:51:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2005-03-30 15:32:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
I installed a minimal FC4t1: unselect all package groups then select only Development and Legacy Devel
Then i did this:

yum install httpd

It first complained about this:

unsigned package httpd-suexec-2.0.53-6.i386.rpm

However, that's minor and i choose to not open a separate bug report.
I tweaked yum.conf then re-run the yum command. It did this:

=================================================================
Transaction Test Succeeded
--> Populating transaction set with selected packages. Please wait.
---> Package apr-util.i386 0:0.9.6-2 set to be updated
---> Package httpd-suexec.i386 0:2.0.53-6 set to be updated
---> Package httpd.i386 0:2.0.53-6 set to be updated
---> Package apr.i386 0:0.9.6-2 set to be updated
Running Transaction
  Installing: apr                          ######################### [1/4]
  Installing: apr-util                     ######################### [2/4]
warning: group apache does not exist - using root
  Installing: httpd-suexec                 ######################### [3/4]
  Installing: httpd                        ######################### [4/4]

Installed: httpd.i386 0:2.0.53-6
Dependency Installed: apr.i386 0:0.9.6-2 apr-util.i386 0:0.9.6-2 httpd-suexec.i386 0:2.0.53-6
Complete!
==============================================================

As you can see, it says there's no apache group.

Version-Release number of selected component (if applicable):
httpd-2.0.53-6

How reproducible:
Didn't try

Steps to Reproduce:
1.see above
2.
3.
  

Actual Results:  see above

Expected Results:  see above

Additional info:
Comment 1 Florin Andrei 2005-03-30 15:36:18 EST
Oh, wait, now i see that the group was actually created when installing the RPM:

Mar 30 12:25:32 ergo useradd[2879]: new group: name=apache, gid=48
Mar 30 12:25:32 ergo useradd[2879]: new user: name=apache, uid=48, gid=48,
home=/var/www, shell=/sbin/nologin

Because the way the message was presented during "yum install" i thought it was
a bug (or was it?)
Comment 2 Florin Andrei 2005-03-30 15:43:59 EST
Hm, i see that a mysql user/group were created while yum-ing the mysql packages,
but this time no warning was printed out by yum.
Comment 3 Joe Orton 2005-03-31 06:22:03 EST
The httpd-suexec package prereqs httpd, so this shouldn't happen.  I expect
someone will mumble something about PreReq being equivalent to Requires to which
I will just laugh.  Both /bin/rpm and anaconda get this right AFAIK.
Comment 4 Paul Nasrat 2005-04-28 07:41:39 EDT
Can you reproduce with latest rpm and yum in rawhide particularly rpm-4.4.1-11
Comment 5 Paul Nasrat 2005-04-28 07:51:19 EDT
httpd-suexec merged back in bug #155716

I assume original cause was when rpm had flattened prereq, which is fixed in
rawhide.

Closing.

Note You need to log in before you can comment on or make changes to this bug.