Bug 1526287 - [3.7.0] No document under .all index for non-ops kibana
Summary: [3.7.0] No document under .all index for non-ops kibana
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.7.z
Assignee: Jeff Cantrill
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1519694 1519705
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-15 06:20 UTC by Junqi Zhao
Modified: 2018-01-23 17:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of: 1519705
Environment:
Last Closed: 2018-01-23 17:59:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
no log entries under .all index (117.02 KB, image/png)
2017-12-18 13:25 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Github fabric8io openshift-elasticsearch-plugin pull 115 None None None 2017-12-15 06:20:40 UTC
Github openshift origin-aggregated-logging pull 835 None None None 2017-12-15 06:20:40 UTC
Github openshift origin-aggregated-logging pull 844 None None None 2017-12-15 06:20:40 UTC
Red Hat Product Errata RHBA-2018:0113 normal SHIPPED_LIVE OpenShift Container Platform 3.7 and 3.6 bug fix and enhancement update 2018-01-23 22:55:59 UTC

Description Junqi Zhao 2017-12-15 06:20:40 UTC
+++ This bug was initially created as a clone of Bug #1519705 +++

Description of problem:

No document under .all index for non-ops kibana when ops is enabled.


Version-Release number of selected component (if applicable):
logging-elasticsearch/images/v3.6.173.0.63-12
logging-elasticsearch/images/v3.6.173.0.63-12
logging-auth-proxy/images/v3.6.173.0.63-11
logging-fluentd/images/v3.6.173.0.63-11


How reproducible:
always

Steps to Reproduce:
1.  Deploy logging and enable ops elasticsearch

openshift_logging_install_logging=true
openshift_logging_image_prefix=registry.example.com/openshift3/
openshift_logging_namespace=logging
openshift_logging_es_cluster_size=1
openshift_logging_es_memory_limit=1Gi

openshift_logging_use_ops=true
openshift_logging_es_ops_memory_limit=1Gi
openshift_logging_es_ops_cluster_size=1


openshift_logging_use_mux=true
openshift_logging_use_mux_client=true




2. cluster-admin search records in non-ops kibana


Actual results:
No records in .all index 

Expected results:
.all index should include records from all projects

Additional info:

Same issue for logging 3.7.0, clone this issue.

Comment 2 Junqi Zhao 2017-12-18 13:24:21 UTC
Issue is not fixed, it is changed to ON-QA by errata.

Tested with logging image version v3.7.14-5, there is still no document under .all index for non-ops kibana, see the attached picture.

Comment 3 Junqi Zhao 2017-12-18 13:25:22 UTC
Created attachment 1369503 [details]
no log entries under .all index

Comment 5 Anping Li 2018-01-12 00:55:38 UTC
Verified in logging:v3.7.22.

Comment 8 errata-xmlrpc 2018-01-23 17:59:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0113


Note You need to log in before you can comment on or make changes to this bug.