Bug 1526368 - Brick Multiplexing: stale brick processes getting created and volume status shows brick as down(pkill glusterfsd glusterfs ,glusterd restart)
Brick Multiplexing: stale brick processes getting created and volume status s...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
3.3
Unspecified Unspecified
urgent Severity urgent
: ---
: RHGS 3.3.1 Async
Assigned To: Atin Mukherjee
nchilaka
brick-multiplexing
: ZStream
Depends On: 1505363 1506513 1508283
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-15 04:55 EST by Sunil Kumar Acharya
Modified: 2018-01-18 06:22 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-52.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1505363
Environment:
Last Closed: 2018-01-10 21:46:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0083 normal SHIPPED_LIVE glusterfs bug fix update 2018-01-11 02:46:21 EST

  None (edit)
Comment 4 nchilaka 2017-12-28 08:26:40 EST
have tried the scenario thrice and didn't see any stale processes.
However I did see cluster.max-bricks-per-process not being honored
hence raised a seperate bug to track the same 
BZ#1529514 - Brick Multiplexing:cluster.max-bricks-per-process not honored(more bricks being attached to glusterfsd) when we do a restart of bricks and glusterd (pkill glusterfsd glusterfs ,glusterd restart)
Comment 5 nchilaka 2017-12-28 08:27:12 EST
moved the bug to verified based on comment#4
Comment 8 errata-xmlrpc 2018-01-10 21:46:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0083

Note You need to log in before you can comment on or make changes to this bug.