Bug 1526372 - Unable to acquire lock for gluster volume leading to 'another transaction in progress' error
Summary: Unable to acquire lock for gluster volume leading to 'another transaction in ...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
(Show other bugs)
Version: 3.3
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
: RHGS 3.3.1 Async
Assignee: Gaurav Yadav
QA Contact: Bala Konda Reddy M
URL:
Whiteboard:
Keywords: ZStream
Depends On: 1442983
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-15 10:01 UTC by Sunil Kumar Acharya
Modified: 2018-08-14 21:20 UTC (History)
18 users (show)

Fixed In Version: glusterfs-3.8.4-52.1
Doc Type: Bug Fix
Doc Text:
While executing multiple volume commands concurrently on the same volume, from different peers of the trusted storage pool, results in one of the glusterd processes from the same pool move to the locked state. Any volume management operations performed on the same volume fails until the glusterd service is restarted on the node where glusterd is in transaction locked state. This release introduces a default transaction lock timeout of 3 minutes. Any glusterd process reaching the locked state will remain there for 3 minutes. Any transactions made, in the process, thereafter will execute successfully.
Story Points: ---
Clone Of: 1442983
Environment:
Last Closed: 2018-01-11 02:46:39 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0083 normal SHIPPED_LIVE glusterfs bug fix update 2018-01-11 07:46:21 UTC
Red Hat Knowledge Base (Solution) 3208541 None None None 2018-04-23 13:52 UTC

Comment 10 Bala Konda Reddy M 2018-01-03 11:28:34 UTC
Verified with 3.8.4-52.3

1. Created 30 volumes on a 3 node setup.
2. On all three nodes started set of volume commands.
while true                                                                      
do                                                                              
gluster volume status                                                           
gluster volume geo-replication test_10 status                                  
gluster snapshot list test_10                                                  
gluster volume quota test_10 list                                              
gluster snapshot info test_10                                                  
gluster volume rebalance test_10 status                                
gluster snapshot status test_10                                                
gluster v status                                                                
done

3. One node acquired lock and on the other nodes it says another transaction in progress.
4. The lock is held for 3 mins.
5. After 3 mins the lock is released. Able to see the output of volume commands.

Hence marking it as verified

Comment 13 errata-xmlrpc 2018-01-11 02:46:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0083


Note You need to log in before you can comment on or make changes to this bug.