Bug 1526385 - subscription-manager-cockpit : Doesnot auto-attach subscriptions anymore while registering
Summary: subscription-manager-cockpit : Doesnot auto-attach subscriptions anymore whil...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: Red Hat subscription-manager QE Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-15 10:25 UTC by Shwetha Kallesh
Modified: 2018-04-10 09:53 UTC (History)
5 users (show)

Fixed In Version: subscription-manager-1.20.10-1
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 09:52:44 UTC


Attachments (Terms of Use)
Observe that subscriptions are still red after registering the system (178.61 KB, image/png)
2017-12-15 10:25 UTC, Shwetha Kallesh
no flags Details
browser console outout (62.66 KB, image/png)
2018-01-12 10:06 UTC, Shwetha Kallesh
no flags Details
Subscriptions are auto-attached and status is green (83.42 KB, image/png)
2018-01-31 07:31 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:53:21 UTC
Github candlepin subscription-manager pull 1752 None None None 2018-01-16 14:10:27 UTC
Github candlepin subscription-manager pull 1760 None None None 2018-01-16 14:06:09 UTC

Description Shwetha Kallesh 2017-12-15 10:25:08 UTC
Created attachment 1368446 [details]
Observe that subscriptions are still red after registering the system

Description of problem:

subscription-manager-cockpit : Doesnot auto-attach subscriptions anymore while registering

Version-Release number of selected component (if applicable):
[root@bkr-hv01-guest15 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.43-1
subscription management rules: 5.26
subscription-manager: 1.20.8-1.el7


How reproducible:


Steps to Reproduce:
1. Open subscriptions tab of cockpit app
2. Click on register button and enter the valid credentials
3. Click on register button

Actual results:
System is registered but subscriptions are not auto-attached

Expected results:
System should be registered but subscriptions should be auto-attached

Additional info:
Tail from /var/log/messages

Dec 15 05:19:10 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:146] Could not import locale for en-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:10 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:118] Could not import locale either for en-US_EN-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:10 bkr-hv01-guest15 rhsm-service: INFO [rhsmlib.dbus.server:200] New connection: <dbus.connection.Connection object at 0x7ff2aeed7950>
Dec 15 05:19:10 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:146] Could not import locale for en-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:10 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:118] Could not import locale either for en-US_EN-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:10 bkr-hv01-guest15 rhsm-service: INFO [rhsm.connection:868] Connection built: host=subscription.rhsm.stage.redhat.com port=443 handler=/subscription auth=basic username=shwetha_tier1_test
Dec 15 05:19:10 bkr-hv01-guest15 rhsm-service: INFO [rhsmlib.facts.dmiinfo:75] Using dmidecode dump file: /dev/mem
Dec 15 05:19:14 bkr-hv01-guest15 subscription-manager: Registered system with identity: a3258df1-0b58-4501-913d-bbbb70542001
Dec 15 05:19:14 bkr-hv01-guest15 rhsm-service: INFO [rhsm.connection:586] Response: status=200, requestUuid=15ef6b56-760c-45ad-ae7f-13d229c21086, request="POST /subscription/consumers"
Dec 15 05:19:14 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.managerlib:71] Consumer created: bkr-hv01-guest15.dsal.lab.eng.bos.redhat.com (a3258df1-0b58-4501-913d-bbbb70542001)
Dec 15 05:19:14 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:146] Could not import locale for en-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:14 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:118] Could not import locale either for en-US_EN-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:14 bkr-hv01-guest15 rhsm-service: INFO [rhsm.connection:868] Connection built: host=subscription.rhsm.stage.redhat.com port=443 handler=/subscription auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
Dec 15 05:19:14 bkr-hv01-guest15 rhsm-service: INFO [rhsm.connection:586] Response: status=200, requestUuid=0113554b-bb88-45c3-8b43-27ba2d0d119e, request="GET /subscription/consumers/a3258df1-0b58-4501-913d-bbbb70542001/compliance"
Dec 15 05:19:15 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.cert_sorter:205] Product status: valid_products= partial_products= expired_products= unentitled_producs=69 future_products= valid_until=None
Dec 15 05:19:15 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:146] Could not import locale for en-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:15 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:118] Could not import locale either for en-US_EN-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:15 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:146] Could not import locale for en-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:15 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:118] Could not import locale either for en-US_EN-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:15 bkr-hv01-guest15 rhsm-service: INFO [rhsm.connection:868] Connection built: host=subscription.rhsm.stage.redhat.com port=443 handler=/subscription auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
Dec 15 05:19:15 bkr-hv01-guest15 dbus[623]: [system] Activating service name='com.redhat.SubscriptionManager' (using servicehelper)
Dec 15 05:19:15 bkr-hv01-guest15 dbus[623]: [system] Successfully activated service 'com.redhat.SubscriptionManager'
Dec 15 05:19:15 bkr-hv01-guest15 rhsm-service: INFO [rhsm.connection:586] Response: status=200, requestUuid=893150c6-7fe1-492b-83d9-cecdf9e2f1d4, request="GET /subscription/consumers/a3258df1-0b58-4501-913d-bbbb70542001/compliance"
Dec 15 05:19:15 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.cert_sorter:205] Product status: valid_products= partial_products= expired_products= unentitled_producs=69 future_products= valid_until=None
Dec 15 05:19:32 bkr-hv01-guest15 rhsm-service: INFO [rhsm.connection:586] Response: status=200, requestUuid=90efba8d-4c96-43bd-b16f-40c4637654fa, request="GET /subscription/consumers/a3258df1-0b58-4501-913d-bbbb70542001"
Dec 15 05:19:32 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:146] Could not import locale for en-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:32 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:118] Could not import locale either for en-US_EN-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:32 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:146] Could not import locale for en-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:32 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:118] Could not import locale either for en-US_EN-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:32 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:146] Could not import locale for en-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:32 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:118] Could not import locale either for en-US_EN-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:32 bkr-hv01-guest15 rhsm-service: INFO [rhsm.connection:868] Connection built: host=subscription.rhsm.stage.redhat.com port=443 handler=/subscription auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
Dec 15 05:19:33 bkr-hv01-guest15 rhsm-service: INFO [rhsm.connection:586] Response: status=200, requestUuid=383e6e99-7656-4b13-b8ed-1e3f0a68a163, request="GET /subscription/consumers/a3258df1-0b58-4501-913d-bbbb70542001/compliance"
Dec 15 05:19:33 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.cert_sorter:205] Product status: valid_products= partial_products= expired_products= unentitled_producs=69 future_products= valid_until=None
Dec 15 05:19:34 bkr-hv01-guest15 rhsm-service: INFO [rhsm.connection:586] Response: status=200, requestUuid=57e5a35f-bac1-48b8-96ff-b5194fbb6e7a, request="GET /subscription/consumers/a3258df1-0b58-4501-913d-bbbb70542001"
Dec 15 05:19:38 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:146] Could not import locale for en-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:38 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.i18n:118] Could not import locale either for en-US_EN-US: [Errno 2] No translation file found for domain: 'rhsm'
Dec 15 05:19:38 bkr-hv01-guest15 rhsm-service: INFO [rhsm.connection:868] Connection built: host=subscription.rhsm.stage.redhat.com port=443 handler=/subscription auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
Dec 15 05:19:39 bkr-hv01-guest15 rhsm-service: INFO [rhsm.connection:586] Response: status=200, requestUuid=7e5d45b3-75dd-40ec-a760-a17d16189861, request="GET /subscription/consumers/a3258df1-0b58-4501-913d-bbbb70542001/compliance"
Dec 15 05:19:39 bkr-hv01-guest15 rhsm-service: INFO [subscription_manager.cert_sorter:205] Product status: valid_products= partial_products= expired_products= unentitled_producs=69 future_products= valid_until=None
Dec 15 05:19:40 bkr-hv01-guest15 rhsm-service: INFO [rhsm.connection:586] Response: status=200, requestUuid=68f8d71c-eacc-4014-af69-70d914685d8d, request="GET /subscription/consumers/a3258df1-0b58-4501-913d-bbbb70542001"

Comment 2 Shwetha Kallesh 2017-12-15 10:29:28 UTC
version of subscription-manager cockpit and cockpit:
[root@bkr-hv01-guest15 ~]# rpm -qa | grep cockpit
cockpit-ws-154-2.el7.x86_64
cockpit-doc-154-2.el7.x86_64
cockpit-bridge-154-2.el7.x86_64
cockpit-154-2.el7.x86_64
cockpit-pcp-154-2.el7.x86_64
cockpit-system-154-2.el7.noarch
subscription-manager-cockpit-1.20.8-1.el7.noarch

Comment 3 Kevin Howell 2018-01-08 15:52:41 UTC
If you can provide Firefox console output, that would be helpful.

Comment 4 Shwetha Kallesh 2018-01-12 10:06:42 UTC
Created attachment 1380377 [details]
browser console outout

Kevin Please find the broswer console output

Comment 6 Shwetha Kallesh 2018-01-31 07:31:44 UTC
Created attachment 1388760 [details]
Subscriptions are auto-attached and status is green

System is registered successfully and subscriptions are auto-attached upon registration. Though the system status is still shown as invalid , upon refreshing the browser the status changes to Green(Current),as there is a separate bug open for it I will move this bug to verified

[root@bkr-hv03-guest18 ~]# rpm -qa | grep cockpit
cockpit-160-2.el7.x86_64
cockpit-bridge-160-2.el7.x86_64
subscription-manager-cockpit-1.20.10-1.el7.noarch
cockpit-system-160-2.el7.noarch
cockpit-ws-160-2.el7.x86_64

Comment 9 errata-xmlrpc 2018-04-10 09:52:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.