Bug 152644 - Movie will not always show
Movie will not always show
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-30 17:25 EST by Ronald Bultje
Modified: 2013-03-13 00:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.3.92
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-14 16:22:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (496 bytes, patch)
2005-03-30 17:26 EST, Ronald Bultje
no flags Details | Diff

  None (edit)
Description Ronald Bultje 2005-03-30 17:25:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922 Epiphany/1.2.7

Description of problem:
For some types of movies (technically, those working with explicit caps), Totem will not show video. The reason is that we try to connect a signal handler to the pad for when the format is known, but we do it on the wrong object. Therefore, the signal handler is never called. This has been long fixed in Totem CVS, but the version in Fedora still suffers, which lead to confusing bug reports from some users.

Attached patch fixes it.

Version-Release number of selected component (if applicable):
totem-0.99.19

How reproducible:
Sometimes

Steps to Reproduce:
1. load a movie (I've been able to reproduce it for divx, for example) in totem.
  

Actual Results:  no video (or: a black window)

Expected Results:  video

Additional info:

See attached patch for a fix.
Comment 1 Ronald Bultje 2005-03-30 17:26:18 EST
Created attachment 112491 [details]
proposed patch

This change will make the signal handler be connected to the correct object,
thereby leading to video being displayed.
Comment 2 Bastien Nocera 2005-05-10 17:41:43 EDT
John, could we merge this patch in FC3, or close the bug as RAWHIDE?
Comment 3 John (J5) Palmieri 2005-05-10 18:01:03 EDT
yes.  I will make a release after I get done with a bunch of fc4 stuff.
Comment 4 John Thacker 2006-04-14 16:22:22 EDT
This has been fixed for a while, so I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.