Bug 152649 - Loosing USB keyboard and mouse when noprobe option is used during RHEL 4 installation
Loosing USB keyboard and mouse when noprobe option is used during RHEL 4 inst...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-30 17:53 EST by Need Real Name
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 18:08:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-03-30 17:53:13 EST
Description of problem:
If 'noprobe' option is used during RHEL4 installation, we don't have any USB 
keyboard and mouse functionality.

How reproducible:
On a platform that has usb keyboard and mouse (no ps/2), start RHEL 4 
installation with noprobe option.

This fails on all architectures.
Comment 1 Jeremy Katz 2005-03-30 18:08:20 EST
With RHEL4, noprobe is really starting to imply more of "noprobe".  There are
finer grained options for specifying if you don't want just, for example,
storage or network probing.

  nonet - don't load network drivers
  nostorage - don't load storage (scsi) drivers
  nousb - don't load usb drivers
  nofirewire - don't load firewire drivers (not relevant for rhel)
  noprobe - the combination of all of the above.
Comment 2 Need Real Name 2005-03-30 18:17:51 EST
That's good to know. Just to be sure. which option is used to prevent usb-
storage from loading, nousb or nostorage?
Comment 3 Jeremy Katz 2005-03-30 18:23:23 EST
nousbstorage is a specific option that catches just usb-storage (and actually,
it doesn't get caught by nostorage... which is probably a bug or at least a
misfeature :).   nousb will cause nousbstorage since you can't load usb-storage
without an hcd.

Note You need to log in before you can comment on or make changes to this bug.