Bug 1526792 - [BZ][RADOS] invalid object count
Summary: [BZ][RADOS] invalid object count
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS   
(Show other bugs)
Version: 2.4
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 3.*
Assignee: Josh Durgin
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-17 13:23 UTC by Benjamin Schmaus
Modified: 2018-04-27 15:17 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-06 17:51:00 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Benjamin Schmaus 2017-12-17 13:23:46 UTC
Description of problem:

Customer is using ceph version 10.2.7-49redhat4.TEST.<customername>xenial (4529937ddde03f48c79d0e0e24e02b20e731d8ab)and showing wrong number of objects for rgw data pool after package upgrades


Version-Release number of selected component (if applicable):
2.4 testfix

How reproducible:
100%

Steps to Reproduce:
1.Displays correct objects before upgrade
2.Upgrade package
3.Displays incorrect objects after upgrade

Actual results:
Incorrect number of objects

Expected results:
Correct number of objects

Additional info:

Comment 6 Benjamin Schmaus 2017-12-17 13:26:42 UTC
Eric Ivancich of my team noted that "the binary representation of  9223372036854775796 is 10000…0001100, which is +12 with the sign bit flipped"--suggesting that this maybe a signed/unsigned mismatch just affecting display  (Presuming they could have 12 objects in this test cluster, rather than 9.)

Comment 14 Matt Benjamin (redhat) 2017-12-19 13:40:05 UTC
@eric, assigning this one to you, until we know more about root cause


Note You need to log in before you can comment on or make changes to this bug.