Bug 152698 - ssl gone. using apt on RH7.2 enigma...
ssl gone. using apt on RH7.2 enigma...
Status: CLOSED NOTABUG
Product: Fedora Legacy
Classification: Retired
Component: General (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-15 19:48 EDT by David Lawrence
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2005-03-30 18:24:24 EST
well, i probably should have let it run but i did.  

I used apt-get with fedoralegacy in the sources file and allowed it to update 
and change some 40+ packages on my system thinking ti was updating a few things 
and correcting required dependencies.  This is NOT a situation where i had to 
type the phrase "yes, i know this could be bad" (sp?).   Generally speaking, the 
system was updated and I had a few updated rpms from RH9 taht would install and 
the odd tarball source install for a few like squid, apache2, openssh.

I didn't even know it had messed up the system until i had a power outage today 
and the system did not come back online on its own (it's a little server system 
used mostly for access to the network from outside).   Anyways, SSH did not 
work, so I had to physically attach a monitor to check logs and screen messages. 
  Essentially, the system failed all kinds of dependencies on boot and somehow 
openssl packages were removed from teh system which prevented sshd from starting 
on boot among other daemons such as apache. It is working again after 
reinstalling a few necesary packages but we are left with a system taht MUST be 
completely reinstalled becase I don't know what else could be wrong taht hasn't 
show up yet; and i really don't trust its setup and configuration anymore.  

findnig fedoralegacy brought a moment of happiness becaseu i knew i had to 
migrate to a new system anyways and saw this as a way to postpone it but i am 
now forced to go ahead with it.

good luck with this project..



------- Additional Comments From jkeating@j2solutions.net 2004-04-15 21:51:01 ----

Unsupported apt, unsupported system configuration (mixed release packages,
source installs, god knows what else....).  I'm sorry it didn't work for your
system, but it wasn't designed for crack-monkey configurations (:



------- Additional Comments From warren@togami.com 2004-04-15 21:54:32 ----

several problems with your report

1) Legacy did not ship any apt tools yet, so you used an unsupported totally
unknown version of apt.  you did not even specify where you got it from, or what
configuration options it has, all of which could have contributed to your
problem.  Also I am guessing since you got the apt tool from elsewhere, you had
other sources in your sources.list.  This very likely could have contributed to
conflicts or package incompatibilities.

2) apt does NOT remove anything from your RPM database unless you say yes,
unless you use some very odd unsupported apt configuration.  Again we have no
idea what you did because you did not use our tool.

3) "odd tarball source install for a few like squid, apache2, openssh."
This is probably key to your problem.  The RPM database KNOWS NOTHING ABOUT
things you installed manually.  You have bypassed the RPM database so anything
you do with RPM packages after this point will be a total unknown.



------- Bug moved to this database by dkl@redhat.com 2005-03-30 18:24 -------

This bug previously known as bug 1490 at https://bugzilla.fedora.us/
https://bugzilla.fedora.us/show_bug.cgi?id=1490
Originally filed under the Fedora Legacy product and General component.

Unknown priority P2. Setting to default priority "normal".
Unknown platform PC. Setting to default platform "All".
Unknown severity major. Setting to default severity "normal".
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here, dkl@redhat.com.
   Previous reporter was silence@m-net.arbornet.org.
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.


Note You need to log in before you can comment on or make changes to this bug.