Bug 152699 - internal compiler error when rpmbuild --rebuild --target i586 openoffice.org-1.1.0-16.src.rpm
internal compiler error when rpmbuild --rebuild --target i586 openoffice.org-...
Status: CLOSED NOTABUG
Product: Fedora Legacy
Classification: Retired
Component: General (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 12:50 EDT by David Lawrence
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2005-03-30 18:24:26 EST
Dear,
below report the latest string output on terminal:

ON=400 -D__DMAKE -DUNIX -DCPPU_ENV=gcc3 -DSUPD=645 -DBUILD=8693 -DPRODUCT
-DNDEBUG -DPRODUCT_FULL -DOSL_DEBUG_LEVEL=0 -DOPTIMIZE -DEXCEPTIONS_ON -DCUI
-DSRX645 -DSHAREDLIB -D_DLL_  -DMULTITHREAD   -o ../../unxlngi4.pro/slo/docvor.o
/usr/src/redhat/BUILD/oo_1.1_src/sfx2/source/doc/docvor.cxx
/usr/src/redhat/BUILD/oo_1.1_src/sfx2/source/doc/docvor.cxx: In constructor
`SfxOrganizeDlg_Impl::SfxOrganizeDlg_Impl(SfxTemplateOrganizeDlg*,
SfxDocumentTemplates*)':
/usr/src/redhat/BUILD/oo_1.1_src/sfx2/source/doc/docvor.cxx:343: internal
compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproduceable, so it is likely a hardware or OS problem
dmake:  Error code 1, while making '../../unxlngi4.pro/slo/docvor.obj'
---* TG_SLO.MK *---
 
ERROR: Error 65280 occurred while making
/usr/src/redhat/BUILD/oo_1.1_src/sfx2/source/doc
error: Bad exit status from /var/tmp/rpm-tmp.73855 (%build)
 
 
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.73855 (%build)



------- Additional Comments From barryn@pobox.com 2004-04-30 11:50:39 ----

If you try again, does it fail on the same line (343) of the same source code
file (docvor.cxx)?

Also, what version of Red Hat are you rebuilding on?



------- Additional Comments From dmarcucci@tiscali.it 2004-05-10 10:57:09 ----

>If you try again, does it fail on the same line (343) of the same source code
file (docvor.cxx)?
No, every times when I rebuild its stopped on different point.

>Also, what version of Red Hat are you rebuilding on?
I rebuilt it on Fedora Core 1 with all pachages update.

I have rebuild it on other PC without problem.
The PC that has rebuild problem has AMD K6-III 450MHz with 384Mb of RAM.
The PC that hasn't rebuild problem has P4 1.7GHz with 512Mb of RAM.

Is possible that its problem depend of the hardware?



------- Additional Comments From barryn@pobox.com 2004-05-10 18:08:41 ----

The problem does not just depend on the hardware. The problem *is* the hardware
-- some component is failing. The most likely causes are the CPU, motherboard,
memory, or power supply. You may want to try the memory test programs at
http://www.memtest86.com or http://www.memtest.org.

I'm closing this bug as INVALID because this is a hardware failure, not a
software bug.



------- Bug moved to this database by dkl@redhat.com 2005-03-30 18:24 -------

This bug previously known as bug 1509 at https://bugzilla.fedora.us/
https://bugzilla.fedora.us/show_bug.cgi?id=1509
Originally filed under the Fedora Legacy product and General component.

Unknown priority P2. Setting to default priority "normal".
Unknown platform PC. Setting to default platform "All".
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here, dkl@redhat.com.
   Previous reporter was dmarcucci@tiscali.it.
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.


Note You need to log in before you can comment on or make changes to this bug.