Bug 1527143 - TimedLogin via custom.conf no longer working (again)
TimedLogin via custom.conf no longer working (again)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.5
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
https://gitlab.gnome.org/GNOME/gnome-...
: Regression
Depends On:
Blocks: 1527213
  Show dependency treegraph
 
Reported: 2017-12-18 11:05 EST by Michael Boisvert
Modified: 2018-05-17 10:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: gnome-shell-3.26.2-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 09:08:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
var/log/gdm files (120.59 KB, application/zip)
2017-12-18 11:05 EST, Michael Boisvert
no flags Details
journalctl -ab (1.51 MB, text/plain)
2017-12-18 11:06 EST, Michael Boisvert
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 09:09 EDT

  None (edit)
Description Michael Boisvert 2017-12-18 11:05:41 EST
Created attachment 1369578 [details]
var/log/gdm files

Description of problem: Timed login via the custom.conf method is not working anymore. 

How reproducible: 100%

Steps to Reproduce:

1. Add following lines into file:  /etc/gdm/custom.conf
          [daemon]
          TimedLoginEnable=true
          TimedLogin=$username
          TimedLoginDelay=10
2. Run "systemctl restart gdm"

Actual results: The timed login progress bar never appears and the user is never automatically logged in after 10 second. 

Expected results: The specified user is automatically logged in after the specified 10 seconds.

More info: Timed login works when the user list is disabled.
Comment 2 Michael Boisvert 2017-12-18 11:06 EST
Created attachment 1369579 [details]
journalctl -ab
Comment 4 Ray Strode [halfline] 2018-02-13 14:16:33 EST
seems to be a mistake introduced when one of the downstream patches got rebased:

+                                                          let currentTime = GLi
+.get_monotonic_time();

should be:

+                                                          let currentTime = GLib.get_monotonic_time();•
Comment 7 Michael Boisvert 2018-02-14 14:24:00 EST
I can verify this now works on gnome-shell-3.26.2-4.el7.
Comment 10 errata-xmlrpc 2018-04-10 09:08:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770

Note You need to log in before you can comment on or make changes to this bug.