Bug 1527319 - ValueError: plural forms expression could be dangerous
Summary: ValueError: plural forms expression could be dangerous
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet
Version: 7.5
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Blivet Maintenance Team
QA Contact: Release Test Team
Petr Bokoc
URL:
Whiteboard: abrt_hash:720a42728001bee54fda25b2756...
Depends On:
Blocks: 1477564 1414011
TreeView+ depends on / blocked
 
Reported: 2017-12-19 08:30 UTC by Peter Kotvan
Modified: 2020-01-27 15:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Selecting the Lithuanian language causes the installer to crash If you select the Lithuanian (Lietuvių) langauge on the first screen of the graphical installer and press `Continue` (Tęsti), the installer crashes and displays a traceback message. To work around this problem, either use a different language, or avoid the graphical installer and use a different approach such as the text mode or a Kickstart installation.
Clone Of:
Environment:
Last Closed: 2020-01-27 15:25:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
File: anaconda-tb (324.59 KB, text/plain)
2017-12-19 08:30 UTC, Peter Kotvan
no flags Details
File: anaconda.log (12.82 KB, text/plain)
2017-12-19 08:30 UTC, Peter Kotvan
no flags Details
File: environ (492 bytes, text/plain)
2017-12-19 08:30 UTC, Peter Kotvan
no flags Details
File: lsblk_output (1.76 KB, text/plain)
2017-12-19 08:30 UTC, Peter Kotvan
no flags Details
File: nmcli_dev_list (1.77 KB, text/plain)
2017-12-19 08:30 UTC, Peter Kotvan
no flags Details
File: os_info (569 bytes, text/plain)
2017-12-19 08:30 UTC, Peter Kotvan
no flags Details
File: program.log (29.15 KB, text/plain)
2017-12-19 08:30 UTC, Peter Kotvan
no flags Details
File: storage.log (68.84 KB, text/plain)
2017-12-19 08:31 UTC, Peter Kotvan
no flags Details
File: syslog (136.91 KB, text/plain)
2017-12-19 08:31 UTC, Peter Kotvan
no flags Details
File: ifcfg.log (1.95 KB, text/plain)
2017-12-19 08:31 UTC, Peter Kotvan
no flags Details
File: packaging.log (27.78 KB, text/plain)
2017-12-19 08:31 UTC, Peter Kotvan
no flags Details

Description Peter Kotvan 2017-12-19 08:30:46 UTC
Description of problem:
I tried to perform and interactive installation of RHEL-7. At welcome screen I selected Lithuanian language and pressed "Tęsti" (Continue). After that this traceback occured.

Version-Release number of selected component:
anaconda-21.48.22.129-1

The following was filed automatically by anaconda:
anaconda 21.48.22.129-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/gettext.py", line 93, in c2py
    raise ValueError, 'plural forms expression could be dangerous'
  File "/usr/lib64/python2.7/gettext.py", line 317, in _parse
    self.plural = c2py(plural)
  File "/usr/lib64/python2.7/gettext.py", line 180, in __init__
    self._parse(fp)
  File "/usr/lib64/python2.7/gettext.py", line 480, in translation
    t = _translations.setdefault(key, class_(fp))
  File "/usr/lib64/python2.7/gettext.py", line 540, in ldgettext
    codeset=_localecodesets.get(domain))
  File "/usr/lib/python2.7/site-packages/blivet/i18n.py", line 26, in <lambda>
    _ = lambda x: gettext.ldgettext("blivet", x) if x != "" else ""
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 84, in <genexpr>
    for p in _binaryPrefixes)
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 88, in _xlated_prefixes
    xlated_binary = list(_xlated_binary_prefixes())
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 292, in humanReadable
    for prefix_item in _xlated_prefixes():
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 225, in __str__
    return self.humanReadable()
  File "/usr/lib/python2.7/site-packages/blivet/devices/storage.py", line 150, in __str__
    s = "%s %s %s" % (exist, self.size, super(StorageDevice, self).__str__())
  File "/usr/lib64/python2.7/logging/__init__.py", line 328, in getMessage
    msg = msg % self.args
  File "/usr/lib64/python2.7/logging/__init__.py", line 464, in format
    record.message = record.getMessage()
  File "/usr/lib64/python2.7/logging/__init__.py", line 724, in format
    return fmt.format(record)
  File "/usr/lib64/python2.7/logging/handlers.py", line 844, in emit
    msg = self.format(record) + '\000'
  File "/usr/lib64/python2.7/site-packages/pyanaconda/anaconda_log.py", line 82, in emit
    SysLogHandler.emit(self, record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 749, in handle
    self.emit(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1318, in callHandlers
    hdlr.handle(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1278, in handle
    self.callHandlers(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1268, in _log
    self.handle(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1149, in info
    self._log(INFO, msg, args, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1997, in updateDeviceFormat
    log.info("updating format of device: %s", device)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/image.py", line 199, in opticalInstallMedia
    devicetree.updateDeviceFormat(dev)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 742, in _initialize
    self._cdrom = opticalInstallMedia(self.storage.devicetree)
  File "/usr/lib64/python2.7/threading.py", line 765, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
ValueError: plural forms expression could be dangerous

Additional info:
addons:         org_fedora_oscap, com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/boot/rhel7-rel-eng/vmlinuz initrd=/boot/rhel7-rel-eng/initrd.img repo=http://192.168.122.1/rhel7-rel-eng/ console=tty0 console=ttyS0 graphical
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.10.0-823.el7.x86_64
product:        Red Hat Enterprise Linux 7
release:        Red Hat Enterprise Linux Workstation release 7.5 Beta (Maipo)
release_type:   pre-release
reproducible:   Not sure how to reproduce the problem
type:           anaconda
version:        7.5

Comment 1 Peter Kotvan 2017-12-19 08:30:49 UTC
Created attachment 1369813 [details]
File: anaconda-tb

Comment 2 Peter Kotvan 2017-12-19 08:30:51 UTC
Created attachment 1369814 [details]
File: anaconda.log

Comment 3 Peter Kotvan 2017-12-19 08:30:52 UTC
Created attachment 1369815 [details]
File: environ

Comment 4 Peter Kotvan 2017-12-19 08:30:54 UTC
Created attachment 1369816 [details]
File: lsblk_output

Comment 5 Peter Kotvan 2017-12-19 08:30:56 UTC
Created attachment 1369817 [details]
File: nmcli_dev_list

Comment 6 Peter Kotvan 2017-12-19 08:30:57 UTC
Created attachment 1369818 [details]
File: os_info

Comment 7 Peter Kotvan 2017-12-19 08:30:59 UTC
Created attachment 1369819 [details]
File: program.log

Comment 8 Peter Kotvan 2017-12-19 08:31:01 UTC
Created attachment 1369820 [details]
File: storage.log

Comment 9 Peter Kotvan 2017-12-19 08:31:03 UTC
Created attachment 1369821 [details]
File: syslog

Comment 10 Peter Kotvan 2017-12-19 08:31:05 UTC
Created attachment 1369822 [details]
File: ifcfg.log

Comment 11 Peter Kotvan 2017-12-19 08:31:07 UTC
Created attachment 1369823 [details]
File: packaging.log

Comment 12 Jiri Konecny 2017-12-19 08:39:22 UTC
This looks like a translation error in the blivet library.
Changing components.

Comment 18 Nerijus Baliūnas 2018-12-05 21:03:39 UTC
7.6 installer does not crash anymore, so this bug can be closed.


Note You need to log in before you can comment on or make changes to this bug.