Bug 1527334 - Various -it vddk -io vddk* options should be documented, removed or fixed
Summary: Various -it vddk -io vddk* options should be documented, removed or fixed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.5
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard: V2V
Depends On: 1621895
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-19 09:21 UTC by mxie@redhat.com
Modified: 2019-08-26 06:44 UTC (History)
6 users (show)

Fixed In Version: libguestfs-1.40.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1636144 (view as bug list)
Environment:
Last Closed: 2019-08-06 12:44:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
invalid-vddk-snapshot.log (3.98 MB, text/plain)
2017-12-19 09:21 UTC, mxie@redhat.com
no flags Details
invalid-vddk-config.log (4.31 MB, text/plain)
2017-12-19 09:22 UTC, mxie@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:2096 None None None 2019-08-06 12:44:35 UTC

Description mxie@redhat.com 2017-12-19 09:21:30 UTC
Created attachment 1369842 [details]
invalid-vddk-snapshot.log

Description of problem:
Will not pop up error/warning when convert guest from vmware using VDDK as a transport with setting invalid value for --vddk-snapshot and --vddk-config option by virt-v2v

Version-Release number of selected component (if applicable):
virt-v2v-1.36.10-4.el7.x86_64
libguestfs-1.36.10-4.el7.x86_64
libvirt-3.9.0-6.el7.x86_64
qemu-kvm-rhev-2.10.0-12.el7.x86_64
libguestfs-winsupport-7.2-2.el7.x86_64
virtio-win-1.9.3-1.el7.noarch
nbdkit-1.1.25.tar.gz 
VMware-vix-disklib-6.5.2-6195444.x86_64.tar.gz

How reproducible:
100%

Steps to reproduce:
1.Convert a snapshot guest from vmware using VMware VDDK as a transport with --vddk-snapshot option,but set invalid value for --vddk-snapshot option

# virt-v2v -ic vpx://vsphere.local%5cAdministrator@10.73.75.182/data/10.73.3.19/?no_verify=1 -it vddk --vddk-libdir /root/vmware-vix-disklib-distrib --vddk-thumbprint 1E:22:D9:AF:A3:00:09:E7:F5:90:0E:C2:D7:19:CD:6F:90:E5:C8:BF  Auto-esx5.5-rhel7.1-snapshot --password-file /tmp/passwd --vddk-snapshot xxadfasdf
[   0.1] Opening the source -i libvirt -ic vpx://vsphere.local%5cAdministrator@10.73.75.182/data/10.73.3.19/?no_verify=1 Auto-esx5.5-rhel7.1-snapshot -it vddk  --vddk-libdir /root/vmware-vix-disklib-distrib --vddk-snapshot xxadfasdf --vddk-thumbprint 1E:22:D9:AF:A3:00:09:E7:F5:90:0E:C2:D7:19:CD:6F:90:E5:C8:BF
[   4.1] Creating an overlay to protect the source from being modified
[  42.2] Initializing the target -o libvirt -os default
[  42.3] Opening the overlay
[  48.9] Inspecting the overlay
[  70.4] Checking for sufficient free disk space in the guest
[  70.4] Estimating space required on target for each disk
[  70.4] Converting Red Hat Enterprise Linux Server 7.1 (Maipo) to run on KVM
virt-v2v: This guest has virtio drivers installed.
[ 200.2] Mapping filesystem data to avoid copying unused and blank areas
[ 200.7] Closing the overlay
[ 201.3] Checking if the guest needs BIOS or UEFI to boot
[ 201.3] Assigning disks to buses
[ 201.3] Copying disk 1/1 to /var/lib/libvirt/images/Auto-esx5.5-rhel7.1-snapshot-sda (raw)
    (100.00/100%)
[ 315.8] Creating output metadata
Pool default refreshed

Domain Auto-esx5.5-rhel7.1-snapshot defined from /tmp/v2vlibvirtc1a5b2.xml

[ 326.1] Finishing off


2.Convert a guest from vmware using VMware VDDK as a transport with --vddk-config option by virt-v2v,but set invalid value for --vddk-config option

# virt-v2v -ic vpx://vsphere.local%5cAdministrator@10.73.199.71/data/10.73.196.89/?no_verify=1 -it vddk --vddk-libdir /root/vmware-vix-disklib-distrib --vddk-thumbprint F3:BD:CC:18:78:A8:DB:66:9F:0C:F0:BF:A6:1A:4D:A0:84:C7:86:26 esx6.5-rhel7.4-x86_64 --password-file /tmp/passwd -o rhv -os 10.73.131.93:/home/nfs_export --vddk-config "ssfasf"
[   0.0] Opening the source -i libvirt -ic vpx://vsphere.local%5cAdministrator@10.73.199.71/data/10.73.196.89/?no_verify=1 esx6.5-rhel7.4-x86_64 -it vddk  --vddk-config ssfasf --vddk-libdir /root/vmware-vix-disklib-distrib --vddk-thumbprint F3:BD:CC:18:78:A8:DB:66:9F:0C:F0:BF:A6:1A:4D:A0:84:C7:86:26
[   3.9] Creating an overlay to protect the source from being modified
[   7.7] Initializing the target -o rhv -os 10.73.131.93:/home/nfs_export
[   7.9] Opening the overlay
[  14.3] Inspecting the overlay
[  60.2] Checking for sufficient free disk space in the guest
[  60.2] Estimating space required on target for each disk
[  60.2] Converting Red Hat Enterprise Linux Server 7.4 (Maipo) to run on KVM
virt-v2v: This guest has virtio drivers installed.
[ 186.2] Mapping filesystem data to avoid copying unused and blank areas
[ 187.1] Closing the overlay
[ 188.3] Checking if the guest needs BIOS or UEFI to boot
[ 188.3] Assigning disks to buses
[ 188.3] Copying disk 1/1 to /tmp/v2v.meUXzS/bdf9c90b-e6f0-439c-aa9f-6305fd5fad7e/images/5a5e06a6-0f40-4636-a89d-ba06462272cb/e833bcc5-a63d-4065-9ef3-b63c92621386 (raw)
^C  (0.00/100%)

Actual results:
As above description

Expected results:
1.Conversion could be failed due to set invalid value for --vddk-snapshot and --vddk-config option when convert guest from vmware using VMware VDDK as a transport
2.There is warning about invalid value of --vddk-snapshot and --vddk-config option when convert guest from vmware using VMware VDDK as a transport

Additional info:

Comment 2 mxie@redhat.com 2017-12-19 09:22:21 UTC
Created attachment 1369843 [details]
invalid-vddk-config.log

Comment 3 Richard W.M. Jones 2017-12-19 09:55:54 UTC
Fairly minor issue so moving to 7.6.

Comment 4 Pino Toscano 2018-07-23 17:16:48 UTC
The file specified for --vddk-config=FILE (or -io vddk-config=FILE) is now checked by nbdkit itself, which will reject unexisting files. This is done in nbdkit >= 1.3.1.

Still there is no validation for --vddk-snapshot.

Comment 5 mxie@redhat.com 2018-08-09 08:24:48 UTC
Test the bug with builds:
virt-v2v-1.38.2-10.el7.x86_64
libguestfs-1.38.2-10.el7.x86_64
libvirt-4.5.0-6.el7.x86_64
qemu-kvm-rhev-2.12.0-9.el7.x86_64
nbdkit-plugin-vddk-1.2.6-1.el7.x86_64


Steps:
1.Set invalid value for vddk-nfchostport during v2v vddk conversion
#  virt-v2v -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA esx6.7-win10-x86_64 --password-file /tmp/passwd -of raw -io vddk-nfchostport=234234
[   0.2] Opening the source -i libvirt -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 esx6.7-win10-x86_64 -it vddk  -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA -io vddk-nfchostport=234234
[   3.1] Creating an overlay to protect the source from being modified
[   4.9] Initializing the target -o libvirt -os default
[   5.0] Opening the overlay
[   9.9] Inspecting the overlay
[  15.9] Checking for sufficient free disk space in the guest
[  15.9] Estimating space required on target for each disk
[  15.9] Converting Windows 10 Enterprise to run on KVM
virt-v2v: warning: /usr/share/virt-tools/pnp_wait.exe is missing.  
Firstboot scripts may conflict with PnP.
virt-v2v: warning: there is no QXL driver for this version of Windows (10.0 
x86_64).  virt-v2v looks for this driver in 
/usr/share/virtio-win/virtio-win.iso

The guest will be configured to use a basic VGA display driver.
virt-v2v: This guest has virtio drivers installed.
[  34.6] Mapping filesystem data to avoid copying unused and blank areas
[  37.6] Closing the overlay
[  39.3] Checking if the guest needs BIOS or UEFI to boot
[  39.3] Assigning disks to buses
[  39.3] Copying disk 1/1 to /var/lib/libvirt/images/default/esx6.7-win10-x86_64-sda (raw)

Result1
   There is no error about invalid value for vddk-nfchostport during v2v vddk conversion


2.Set invalid value for vddk-cookie during v2v vddk conversion 
virt-v2v -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA esx6.7-win10-x86_64 --password-file /tmp/passwd -of raw -io vddk-cookie=1333343
[   0.1] Opening the source -i libvirt -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 esx6.7-win10-x86_64 -it vddk  -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA -io vddk-cookie=1333343
[   3.0] Creating an overlay to protect the source from being modified
nbdkit: error: VixDiskLibVim: Login failure. Callback error 3014 at 2500.

(process:23074): GLib-GObject-CRITICAL **: g_signal_handler_disconnect: assertion `handler_id > 0' failed
nbdkit: error: VixDiskLib_Open: [esx6.7] esx6.7-win10-x86_64/esx6.7-win10-x86_64.vmdk: Insufficient permissions in the host operating system
qemu-img: /var/tmp/v2vovlda415e.qcow2: Failed to read data: Unexpected end-of-file before all bytes were read
Could not open backing image to determine size.
virt-v2v: error: qemu-img command failed, see earlier errors

If reporting bugs, run virt-v2v with debugging enabled and include the 
complete output:

  virt-v2v -v -x [...]


Result1
    The conversion is failed because of invalid value for vddk-cookie but the error is not clear


3.Set invalid value for vddk-config during v2v vddk conversion 
#  virt-v2v -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA esx6.7-win10-x86_64 --password-file /tmp/passwd -of raw -io vddk-config=mxiemxie
[   0.1] Opening the source -i libvirt -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 esx6.7-win10-x86_64 -it vddk  -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA -io vddk-config=mxiemxie
nbdkit: error: VixDiskLib: Unable to load configuration options from /home/mxiemxie.
[   3.0] Creating an overlay to protect the source from being modified
[   6.9] Initializing the target -o libvirt -os default
[   7.0] Opening the overlay
[  15.8] Inspecting the overlay

Result3:
    There is error about invalid value for vddk-config during v2v vddk conversion


4.Set invalid value for vddk-port during v2v vddk conversion 
#virt-v2v -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA esx6.7-win10-x86_64 --password-file /tmp/passwd -of raw -io vddk-port=234234
[   0.1] Opening the source -i libvirt -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 esx6.7-win10-x86_64 -it vddk  -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA -io vddk-port=234234
[   3.0] Creating an overlay to protect the source from being modified
nbdkit: error: VixDiskLibVim: Login failure. Callback error 18000 at 2500.
nbdkit: error: VixDiskLib_Open: [esx6.7] esx6.7-win10-x86_64/esx6.7-win10-x86_64.vmdk: Cannot connect to the host
qemu-img: /var/tmp/v2vovl18e934.qcow2: Failed to read data: Unexpected end-of-file before all bytes were read
Could not open backing image to determine size.
virt-v2v: error: qemu-img command failed, see earlier errors

If reporting bugs, run virt-v2v with debugging enabled and include the 
complete output:

  virt-v2v -v -x [...]

Result4:
  The conversion is failed because of invalid value for vddk-port but the error is not clear


5.Set invalid value for vddk-snapshot during v2v vddk conversion 
#  virt-v2v -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA esx6.7-win10-x86_64 --password-file /tmp/passwd -of raw -io vddk-snapshot=xxadfasdf
[   0.4] Opening the source -i libvirt -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 esx6.7-win10-x86_64 -it vddk  -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA -io vddk-snapshot=xxadfasdf
[   4.5] Creating an overlay to protect the source from being modified
[   8.1] Initializing the target -o libvirt -os default
[   8.3] Opening the overlay
[  21.3] Inspecting the overlay
[  29.4] Checking for sufficient free disk space in the guest
[  29.4] Estimating space required on target for each disk
[  29.4] Converting Windows 10 Enterprise to run on KVM
virt-v2v: warning: /usr/share/virt-tools/pnp_wait.exe is missing.  
Firstboot scripts may conflict with PnP.
virt-v2v: warning: there is no QXL driver for this version of Windows (10.0 
x86_64).  virt-v2v looks for this driver in 
/usr/share/virtio-win/virtio-win.iso

The guest will be configured to use a basic VGA display driver.
virt-v2v: This guest has virtio drivers installed.
[  52.8] Mapping filesystem data to avoid copying unused and blank areas
[  53.6] Closing the overlay
[  55.1] Checking if the guest needs BIOS or UEFI to boot
[  55.1] Assigning disks to buses
[  55.1] Copying disk 1/1 to /var/lib/libvirt/images/default/esx6.7-win10-x86_64-sda (raw)


Result5:
    There is no error about invalid value for vddk-snapshot during v2v vddk conversion


6.Set invalid value for vddk-transports during v2v vddk conversion 
#  virt-v2v -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA esx6.7-win10-x86_64 --password-file /tmp/passwd -of raw -io vddk-transports==xxa:ddd
[   0.1] Opening the source -i libvirt -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 esx6.7-win10-x86_64 -it vddk  -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA -io vddk-transports==xxa:ddd
[   3.0] Creating an overlay to protect the source from being modified
nbdkit: error: VixDiskLib_ConnectEx: One of the parameters was invalid
qemu-img: /var/tmp/v2vovl900e7b.qcow2: Failed to read data: Unexpected end-of-file before all bytes were read
Could not open backing image to determine size.
virt-v2v: error: qemu-img command failed, see earlier errors

If reporting bugs, run virt-v2v with debugging enabled and include the 
complete output:

  virt-v2v -v -x [...]

Result6:
    There is ndkit error " One of the parameters was invalid " but the error should point out which parameter is wrong


7.Set invalid value for vddk-vimapiver during v2v vddk conversion 
#  virt-v2v -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA esx6.7-win10-x86_64 --password-file /tmp/passwd -of raw -io vddk-vimapiver=wsdfedf
[   0.1] Opening the source -i libvirt -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 esx6.7-win10-x86_64 -it vddk  -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA -io vddk-vimapiver=wsdfedf
[   3.1] Creating an overlay to protect the source from being modified
[   7.0] Initializing the target -o libvirt -os default
[   7.1] Opening the overlay
[  15.1] Inspecting the overlay
[  20.8] Checking for sufficient free disk space in the guest
[  20.8] Estimating space required on target for each disk
[  20.8] Converting Windows 10 Enterprise to run on KVM
virt-v2v: warning: /usr/share/virt-tools/pnp_wait.exe is missing.  
Firstboot scripts may conflict with PnP.
virt-v2v: warning: there is no QXL driver for this version of Windows (10.0 
x86_64).  virt-v2v looks for this driver in 
/usr/share/virtio-win/virtio-win.iso

The guest will be configured to use a basic VGA display driver.
virt-v2v: This guest has virtio drivers installed.
[  41.1] Mapping filesystem data to avoid copying unused and blank areas
[  41.8] Closing the overlay
[  43.0] Checking if the guest needs BIOS or UEFI to boot
[  43.0] Assigning disks to buses
[  43.0] Copying disk 1/1 to /var/lib/libvirt/images/default/esx6.7-win10-x86_64-sda (raw)

Result7
   There is no error about invalid value for vddk-vimapiver during v2v vddk conversion

Comment 6 Richard W.M. Jones 2018-09-26 09:26:30 UTC
The major fix happened upstream in:
  https://github.com/libguestfs/nbdkit/commit/8d7f7c26eb435334d7fa35e84ceee7d266dfae4c

This change ensured that both config and libdir parameters now
have an effect.

This change was backported to nbdkit 1.2.6 in RHEL 7.6 and
nbdkit 1.4.2 in RHEL 8.0:
  https://github.com/libguestfs/nbdkit/commits/rhel-7.6
  https://github.com/libguestfs/nbdkit/commits/rhel-8.0

About the other settings:

nfchostport: This only has an effect if using VDDK >= 5.5.5
or VDDK >= 6.0.1.  I don't know which version of VDDK you are
using for this test.

cookie: It's expected that authentication will fail if you set
this, so .. don't set this.

port: Again, setting this to an invalid port causes an error, but
the error is from VDDK and we don't change it.

transports: Again, don't set it unless you know what you're doing.

We can probably deal with the above settings by adding something to
the manual saying something like "don't set these unless you know
what you're doing".

  https://www.redhat.com/archives/libguestfs/2018-September/msg00157.html

vimapiver: In the latest VDDK plugin this parameter is ignored.
We should remove it from virt-v2v.

  https://www.redhat.com/archives/libguestfs/2018-September/msg00156.html

snapshot: This one is serious, since setting the snapshot _ought_
to select a snapshot from the remote image, but it obviously
doesn't work or is being ignored for some reason.

Comment 7 Richard W.M. Jones 2018-10-04 14:35:07 UTC
I've added two patches upstream to address most of the issues:

https://github.com/libguestfs/libguestfs/commit/42d10f0b0e596f8d8b2c1a0311edd966801b6c89
https://github.com/libguestfs/libguestfs/commit/0e575234fd650285ca1211373632a839a9ab11be

However this does NOT address the final issue which needs further
investigation:

| snapshot: This one is serious, since setting the snapshot _ought_
| to select a snapshot from the remote image, but it obviously
| doesn't work or is being ignored for some reason.

Comment 8 Richard W.M. Jones 2018-10-04 14:39:01 UTC
I created a new bug (bug 1636144) for the snapshot issue.

Comment 9 Pino Toscano 2019-01-17 11:57:46 UTC
This bug will be fixed by the rebase scheduled for RHEL 7.7, see bug 1621895.

Comment 11 liuzi 2019-03-13 07:23:30 UTC
Test bug with builds:
libguestfs-1.40.2-1.el7.x86_64
virt-v2v-1.40.2-1.el7.x86_64
libvirt-4.5.0-10.el7_6.4.x86_64

Steps:
1.Check whether various -it vddk -io vddk* options had be documented:
1.1 Check the virt-v2v-input-vmware
#man virt-v2v-input-vmware

Other options that you might need to add in rare circumstances include -io vddk-config, -io vddk-cookie, -io vddk-nfchostport, -io vddk-port, -io vddk-snapshot, and -io vddk-transports, which are all explained in the nbdkit-vddk-plugin(1) documentation. Do not use these options unless you know what you are doing.

1.2.Check the virt-v2v manual
#man virt-v2v

-io vddk-config=FILENAME
-io vddk-cookie=COOKIE
-io vddk-nfchostport=PORT
-io vddk-port=PORT
-io vddk-snapshot=SNAPSHOT-MOREF
-io vddk-transports=MODE:MODE:...
When using VDDK mode, these options are passed unmodified to the nbdkit(1) VDDK plugin.
Please refer to nbdkit-vddk-plugin(1). Do not use these options unless you know what you
are doing. These are all optional.

2.Check whether the vimapiver option had been removed.
# man virt-v2v-input-vmware|grep vimapiver
output nothing
# man virt-v2v|grep vimapiver
output nothing
# virt-v2v -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA esx6.7-win10-x86_64 --password-file /tmp/passwd -of raw -io vddk-vimapiver=wsdfedf
virt-v2v: error: -it vddk: ‘-io vddk-vimapiver’ is not a valid input
option

If reporting bugs, run virt-v2v with debugging enabled and include the
complete output:

virt-v2v -v -x [...]

Result:Various -it vddk -io vddk* options had been documented, -io vddk-vimapiver option had been removed.

Comment 12 liuzi 2019-04-16 07:56:12 UTC
Verify bug with builds:
virt-v2v-1.40.2-2.el7.x86_64
libguestfs-1.40.2-2.el7.x86_64

Steps:
1.Check whether various -it vddk -io vddk* options had be documented:
1.1 Check the virt-v2v-input-vmware
#man virt-v2v-input-vmware

Other options that you might need to add in rare circumstances include -io vddk-config, -io vddk-cookie, -io vddk-nfchostport, -io vddk-port, -io vddk-snapshot, and -io vddk-transports, which are all explained in the nbdkit-vddk-plugin(1) documentation. Do not use these options unless you know what you are doing.

1.2.Check the virt-v2v manual
#man virt-v2v

-io vddk-config=FILENAME
-io vddk-cookie=COOKIE
-io vddk-nfchostport=PORT
-io vddk-port=PORT
-io vddk-snapshot=SNAPSHOT-MOREF
-io vddk-transports=MODE:MODE:...
When using VDDK mode, these options are passed unmodified to the nbdkit(1) VDDK plugin.
Please refer to nbdkit-vddk-plugin(1). Do not use these options unless you know what you
are doing. These are all optional.

2.Check whether the vimapiver option had been removed.
# man virt-v2v-input-vmware|grep vimapiver
output nothing
# man virt-v2v|grep vimapiver
output nothing
# virt-v2v -ic vpx://vsphere.local%5cAdministrator@10.73.73.141/data/10.73.75.219/?no_verify=1 -it vddk -io vddk-libdir=/home/vmware-vix-disklib-distrib -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA esx6.7-win10-x86_64 --password-file /tmp/passwd -of raw -io vddk-vimapiver=wsdfedf
virt-v2v: error: -it vddk: ‘-io vddk-vimapiver’ is not a valid input
option

If reporting bugs, run virt-v2v with debugging enabled and include the
complete output:

virt-v2v -v -x [...]

Result:Various -it vddk -io vddk* options had been documented, -io vddk-vimapiver option had been removed.so change the bug from ON_QA to VERIFIED.

Comment 14 errata-xmlrpc 2019-08-06 12:44:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2096


Note You need to log in before you can comment on or make changes to this bug.