Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1527392 - subscription-manager-cockpit : Text fields in the "Register" dialog doesnt clear the data at all
subscription-manager-cockpit : Text fields in the "Register" dialog doesnt cl...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.5
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Jiri Hnidek
Red Hat subscription-manager QE Team
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-19 06:02 EST by Rehana
Modified: 2018-04-10 05:53 EDT (History)
6 users (show)

See Also:
Fixed In Version: subscription-manager-1.20.10-1
Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 05:52:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proxy details still remain upon unregister (108.66 KB, image/png)
2018-01-31 02:42 EST, Shwetha Kallesh
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Github candlepin/subscription-manager/pull/1756 None None None 2018-01-12 08:25 EST
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 05:53 EDT

  None (edit)
Description Rehana 2017-12-19 06:02:08 EST
Description of problem:


Version-Release number of selected component (if applicable):
subscription-manager-1.20.8-1.el7.x86_64
subscription-manager-rhsm-certificates-1.20.8-1.el7.x86_64
subscription-manager-rhsm-1.20.8-1.el7.x86_64
subscription-manager-gui-1.20.8-1.el7.x86_64
subscription-manager-cockpit-1.20.8-1.el7.noarch
subscription-manager-initial-setup-addon-1.20.8-1.el7.x86_64
subscription-manager-plugin-container-1.20.8-1.el7.x86_64
cockpit-system-154-2.el7.noarch
cockpit-154-2.el7.x86_64
cockpit-bridge-154-2.el7.x86_64
subscription-manager-cockpit-1.20.8-1.el7.noarch
cockpit-ws-154-2.el7.x86_64


How reproducible:
always

Steps to Reproduce:
1.Try to register the system using cockpit
2.enter the details needed 
3.register
4.now unregister and try to register --(A)
5.also configure the proxy details in rhsm.conf
6.Try to register , you see that proxy details are populated ( working fine)
7. now remove the proxy details from rhsm.conf
8. launch cockpit and try to register again --(B)

Actual results:
(A) Observed the fields still loads the username and password even after clearing the browser caches/

(B) Even though the system is no longer configured to use the proxy , cockpit register dialog still displays the proxy details

Expected results:
Test field should be cleared. 

Additional info:
Comment 2 Shwetha Kallesh 2018-01-31 02:42 EST
Created attachment 1388763 [details]
proxy details still remain upon unregister

Moving bug to back to new as the text fields of register dialogue are cleared but proxy details still remain upon unregistering 

[root@bkr-hv03-guest18 ~]# rpm -qa | grep cockpit
cockpit-160-2.el7.x86_64
cockpit-bridge-160-2.el7.x86_64
subscription-manager-cockpit-1.20.10-1.el7.noarch
cockpit-system-160-2.el7.noarch
cockpit-ws-160-2.el7.x86_64
Comment 3 Kevin Howell 2018-01-31 15:50:20 EST
> Moving bug to back to new as the text fields of register dialogue are cleared but proxy details still remain upon unregistering.

These fields are being pulled from rhsm.conf, similar to serverurl. Since the expectation is that upon successful registration, these details are saved to rhsm.conf and also the cockpit UI should respect settings from rhsm.conf, I think it's reasonable that they are present after unregistering. Thoughts?
Comment 4 Rehana 2018-02-01 09:11:55 EST
Hi Kevin,

I agree that the text field of register option are now getting cleared. However for the proxy ,When user removes the proxy entries from rhsm.conf( by manually or CLI) the Proxy details are *NOT* getting removed from the cockpit UI. But if the user restarts rhsm.service then the proxy entry is getting removed 

I just wanted to confirm if user makes any changes in the rhsm.conf file , the rhsm.service needs to be restarted to see the changes on the cockpit ?
Comment 5 Kevin Howell 2018-02-05 16:58:03 EST
> I just wanted to confirm if user makes any changes in the rhsm.conf file , the rhsm.service needs to be restarted to see the changes on the cockpit ?

Correct. We are tracking this in bug 1504588.
Comment 6 Rehana 2018-02-09 09:08:02 EST
(In reply to Kevin Howell from comment #5)
> > I just wanted to confirm if user makes any changes in the rhsm.conf file , the rhsm.service needs to be restarted to see the changes on the cockpit ?
> 
> Correct. We are tracking this in bug 1504588.

Hi Kevin,

Can we switch this bug to on_qa then ? I can verify the text field clearing part as the other observation is tracked in bug 1504588

thanks.
Rehana
Comment 7 Rehana 2018-02-13 12:11:42 EST
Verifying on :
============
subscription-manager-rhsm-1.20.10-1.el7.x86_64
subscription-manager-initial-setup-addon-1.20.10-1.el7.x86_64
subscription-manager-gui-1.20.10-1.el7.x86_64
subscription-manager-rhsm-certificates-1.20.10-1.el7.x86_64
subscription-manager-cockpit-1.20.10-1.el7.noarch
cockpit-160-2.el7.x86_64
subscription-manager-1.20.10-1.el7.x86_64
 

Steps followed:

1.Try to register the system using cockpit
2.enter the details needed 
3.register
4.now unregister and try to register again

Observed that now the Text fields in the Register Dialog are cleared.

Note: The observation regarding reflecting any change of rhsm config parameters in cockpit will be tracked in the bug 1504588 as per comment 6

Based on the above observations marking the bug as Verified!!
Comment 10 errata-xmlrpc 2018-04-10 05:52:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681

Note You need to log in before you can comment on or make changes to this bug.