Bug 1527438 - The issue with metric_processing_delay is not fixed
Summary: The issue with metric_processing_delay is not fixed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Pradeep Kilambi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-19 12:11 UTC by Sasha Smolyak
Modified: 2018-06-27 13:42 UTC (History)
3 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180122224017.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:40:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 531192 None master: MERGED tripleo-heat-templates: Drop redundant delay param (Ic0e9eb9480b62c49363067e3b64400074fd4b626) 2018-02-07 14:16:01 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:42:00 UTC

Description Sasha Smolyak 2017-12-19 12:11:18 UTC
Description of problem:
Follow-up of cherry-picked fix for this bz: https://bugzilla.redhat.com/show_bug.cgi?id=1414271

There are still remainings of the same code in /usr/share/openstack-tripleo-heat-templates/puppet/services/gnocchi-base.yaml:

  MetricProcessingDelay:
    default: 30
    description: Delay between processing metrics.

        gnocchi::storage::metric_processing_delay: {get_param: MetricProcessingDelay}

And accordingly, we now see metric_processing_delay twice in the same /etc/gnocchi/gnocchi.conf: in metricd section and in oslo_messaging section, and it definitely doesn't belong to oslo_messageing

We need to clean it from there.

Version-Release number of selected component (if applicable):
openstack-gnocchi-common-4.0.3-2.el7ost.noarch
puppet-gnocchi-11.3.0-2.el7ost.noarch
openstack-gnocchi-metricd-4.0.3-2.el7ost.noarch
python-gnocchiclient-3.3.1-1.el7ost.noarch
openstack-gnocchi-api-4.0.3-2.el7ost.noarch
openstack-gnocchi-indexer-sqlalchemy-4.0.3-2.el7ost.noarch
openstack-gnocchi-statsd-4.0.3-2.el7ost.noarch
python-gnocchi-4.0.3-2.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud with 
custom_templates: 
    parameter_defaults:
        MetricProcessingDelay: 15

2. Go to controller, observe gnocchi.conf:
sudo docker exec -ti gnocchi_api vi /etc/gnocchi/gnocchi.conf


Actual results:
metric_processing_delay appears twice in the conf file

Expected results:
It's supposed to appear only in metricd section

Additional info:

Comment 1 Pradeep Kilambi 2018-01-04 13:53:49 UTC
this should be fixed, we just need to pull in new packages. I'll look into it.

Comment 8 errata-xmlrpc 2018-06-27 13:40:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.