Bug 1527772 - remove ExclusiveArch directive from SPEC file
remove ExclusiveArch directive from SPEC file
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: build (Show other bugs)
3.3
Unspecified Unspecified
high Severity high
: ---
: RHGS 3.3.1 Async
Assigned To: Milind Changire
Vivek Das
: ZStream
Depends On:
Blocks: 1445922 1534253
  Show dependency treegraph
 
Reported: 2017-12-20 00:24 EST by Milind Changire
Modified: 2018-01-14 10:01 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-52.2
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1534253 (view as bug list)
Environment:
Last Closed: 2018-01-10 21:46:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0083 normal SHIPPED_LIVE glusterfs bug fix update 2018-01-11 02:46:21 EST

  None (edit)
Description Milind Changire 2017-12-20 00:24:08 EST
Description of problem:
ExclusiveArch: x86_64 aarch64

The above directive in the SPEC file prohibits builds for other architectures.
This should be removed so that builds can be done for choice of architectures whenever required
Comment 6 Yaakov Selkowitz 2017-12-20 10:22:08 EST
How will this get to the 3.4.0 branch too?
Comment 7 Atin Mukherjee 2017-12-20 23:23:39 EST
(In reply to Yaakov Selkowitz from comment #6)
> How will this get to the 3.4.0 branch too?

The same changes done in 3.3.1 branch will be taken care in 3.4.0 branch as well through BZ 1527773.
Comment 8 Vivek Das 2017-12-28 07:13:40 EST
Verified the bug in build log of the concerned errata.
Checked for the patch that includes the removal of "ExclusiveArch: x86_64 aarch64".
Marking the bug as verified.
Comment 10 errata-xmlrpc 2018-01-10 21:46:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0083

Note You need to log in before you can comment on or make changes to this bug.