Bug 1527813 - Subscription-manager-gui - online documentation throws 404 error
Summary: Subscription-manager-gui - online documentation throws 404 error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: Red Hat subscription-manager QE Team
URL:
Whiteboard:
: 1540237 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-20 08:01 UTC by Shwetha Kallesh
Modified: 2018-04-10 09:53 UTC (History)
6 users (show)

Fixed In Version: subscription-manager-1.20.10-1
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 09:52:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
404 Error (233.19 KB, image/png)
2017-12-20 08:01 UTC, Shwetha Kallesh
no flags Details
Documentation does open now and no more 404 error (379.98 KB, image/png)
2018-01-31 08:38 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:53:21 UTC
Github candlepin subscription-manager pull 1763 None None None 2018-01-19 13:58:19 UTC

Description Shwetha Kallesh 2017-12-20 08:01:19 UTC
Created attachment 1370334 [details]
404 Error

Description of problem:
When I try to open online documentation , I get 404 error on browser

Version-Release number of selected component (if applicable):
[root@dhcp182-10 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.43-1
subscription management rules: 5.26
subscription-manager: 1.20.8-1.el7


How reproducible:


Steps to Reproduce:
1.Launch GUI
2. Click on help -----> Online Documentation
3.

Actual results:

404 Error
P.S Attachment: 404 Error 

Expected results:
Document should open without any error

Additional info:

Comment 2 Kevin Howell 2018-01-08 15:29:17 UTC
Please include the URL. More investigation is definitely needed.

Comment 3 Shwetha Kallesh 2018-01-12 10:14:56 UTC
 https://access.redhat.com/documentation/Red_Hat_Subscription_Management/ is the url that throws 404 error.
 Also note that the documentation opens when you try to open for the second time

Comment 4 Jiri Hnidek 2018-01-16 10:33:34 UTC
I tried to open the "Online Documentation" today morning and it works as expected. Web server redirects now to page: https://access.redhat.com/documentation/en-us/red_hat_subscription_management/. I did not notice any problem during opening of documentation with other locales (Czech, Germany).

It seems that there were some changes in configuration of web server and it works now. I'm considering it as NOTABUG now. Thoughts?

Comment 5 Kevin Howell 2018-01-18 17:53:09 UTC
> I tried to open the "Online Documentation" today morning and it works as expected. Web server redirects now to page: https://access.redhat.com/documentation/en-us/red_hat_subscription_management/. I did not notice any problem during opening of documentation with other locales (Czech, Germany).

I wonder if this has changed once more? I tried to visit https://access.redhat.com/documentation/Red_Hat_Subscription_Management/?locale=en-us and https://access.redhat.com/documentation/Red_Hat_Subscription_Management/?locale=de-de and got 404...

Looks like the locales are currently handled as part of the URI path (example: https://access.redhat.com/documentation/de-de/red_hat_subscription_management/
https://access.redhat.com/documentation/en-us/red_hat_subscription_management/ ) Let's ask around and confirm what the proper URL should be, and whether our current URLs should work...

Comment 7 Shwetha Kallesh 2018-01-31 08:38:59 UTC
Created attachment 1388803 [details]
Documentation does open now and no more 404 error

Documentation does open now and no more 404 error , so moving bug to verified

[root@bkr-hv03-guest18 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.3.0-1
subscription management rules: 5.26
subscription-manager: 1.20.10-1.el7

Comment 8 Kevin Howell 2018-02-01 15:29:20 UTC
*** Bug 1540237 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2018-04-10 09:52:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.