Bug 1527866 - Initial hosted-engine VM not deleted properly after ansible SHE deployment.
Summary: Initial hosted-engine VM not deleted properly after ansible SHE deployment.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: ovirt-4.2.1
: ---
Assignee: Doron Fediuck
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-20 09:52 UTC by Nikolai Sednev
Modified: 2018-02-12 11:54 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.2.1.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-12 11:54:24 UTC
oVirt Team: SLA
dfediuck: ovirt-4.2?
nsednev: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
Screenshot from 2017-11-16 17-10-29.png (94.99 KB, image/png)
2017-12-20 09:53 UTC, Nikolai Sednev
no flags Details
engine logs (520.66 KB, application/x-gzip)
2017-12-21 11:17 UTC, Nikolai Sednev
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 85674 master MERGED core: prevent an exception on adding an external VM 2017-12-24 17:10:35 UTC
oVirt gerrit 85727 master ABANDONED ansible: Remove external VM 2018-01-16 11:20:46 UTC
oVirt gerrit 86372 None None None 2018-01-17 11:24:53 UTC

Description Nikolai Sednev 2017-12-20 09:52:29 UTC
Description of problem:
Initial hosted-engine VM not deleted properly after ansible SHE deployment.
I see two hostedengineansible VMs, first one shown as external-hostedengineansible and its down, second shown as hostedengineansible and its up. See photo for more details.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Deploy ansible SHE.

Actual results:
Initial SHE-VM not wiped out properly and shown as external-hostedengineansiblein UI and its down.

Expected results:
Initial SHE-VM should be wiped out properly.

Additional info:
See the attached screenshot.

Comment 1 Nikolai Sednev 2017-12-20 09:53:41 UTC
Created attachment 1370377 [details]
Screenshot from 2017-11-16 17-10-29.png

Comment 2 Yaniv Kaul 2017-12-21 07:41:08 UTC
Can you provide some logs?
Perhaps it's related to the exception in Engine in detecting the external VMs that we've seen?

Comment 3 Nikolai Sednev 2017-12-21 11:17:02 UTC
Created attachment 1370834 [details]
engine logs

Comment 4 Nikolai Sednev 2018-01-22 15:51:43 UTC
Works for me just fine on these components:
ovirt-hosted-engine-setup-2.2.7-0.0.master.20180119084226.git3799ea2.el7.centos.noarch
ovirt-hosted-engine-ha-2.2.5-0.0.master.20180117160214.20180117160210.gitd5b58a8.el7.centos.noarch
ovirt-engine-appliance-4.2-20180121.1.el7.centos.noarch

Moving to verified.

Comment 5 Sandro Bonazzola 2018-02-12 11:54:24 UTC
This bugzilla is included in oVirt 4.2.1 release, published on Feb 12th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.