Bug 1527945 - [fix available] Segmentation fault when opening password protected LO document
Summary: [fix available] Segmentation fault when opening password protected LO document
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libreoffice
Version: 7.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Caolan McNamara
QA Contact: Desktop QE
Jana Heves
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-20 14:53 UTC by Martin Krajnak
Modified: 2018-04-10 12:05 UTC (History)
5 users (show)

Fixed In Version: libreoffice-5.3.6.1-6.el7
Doc Type: Known Issue
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 12:04:37 UTC


Attachments (Terms of Use)
password protected document (12.39 KB, application/vnd.oasis.opendocument.text)
2017-12-20 14:53 UTC, Martin Krajnak
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0751 None None None 2018-04-10 12:05:32 UTC

Description Martin Krajnak 2017-12-20 14:53:09 UTC
Created attachment 1370498 [details]
password protected document

Version-Release number of selected component (if applicable):
libreofficekit-5.3.6.1-5.el7.x86_64
gnome-documents-3.22.2-8.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.Open gnome-documents
2.Open TestPasswordProtectedPDF

Actual results:
(gdb) continue
Continuing.
[Thread 0x7f70b03ff700 (LWP 24784) exited]
[New Thread 0x7f70b03ff700 (LWP 24906)]
[New Thread 0x7f70af2ff700 (LWP 24907)]
[New Thread 0x7f70c6bb1700 (LWP 24911)]
[New Thread 0x7f70c57ba700 (LWP 24912)]
[New Thread 0x7f70ae6fe700 (LWP 24913)]
[New Thread 0x7f70adefd700 (LWP 24914)]
[Thread 0x7f70adefd700 (LWP 24914) exited]
[Thread 0x7f70ae6fe700 (LWP 24913) exited]
[Thread 0x7f70af2ff700 (LWP 24907) exited]
[Thread 0x7f70c57ba700 (LWP 24912) exited]
[Thread 0x7f70c6bb1700 (LWP 24911) exited]
[New Thread 0x7f70c6bb1700 (LWP 24918)]
[New Thread 0x7f70c57ba700 (LWP 24919)]
Detaching after fork from child process 24920.
[New Thread 0x7f70af2ff700 (LWP 24921)]
warning: Corrupted shared library list: 0x7f70c00d52d0 != 0x7f70c00d1b10

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f70b03ff700 (LWP 24906)]
0x00007f70adcd4ccf in lokThreadFunc(void*, void*) () from /lib64/liblibreofficekitgtk.so
Missing separate debuginfos, use: debuginfo-install avahi-libs-0.6.31-19.el7.x86_64 boost-filesystem-1.53.0-27.el7.x86_64 boost-iostreams-1.53.0-27.el7.x86_64 boost-system-1.53.0-27.el7.x86_64 lcms2-2.6-3.el7.x86_64 liblangtag-0.6.2-1.1.el7.x86_64 liborcus-0.12.1-2.el7.x86_64 libreoffice-core-5.3.6.1-5.el7.x86_64 libreoffice-ure-5.3.6.1-5.el7.x86_64 libreofficekit-5.3.6.1-5.el7.x86_64
(gdb) backtrace 
#0  0x00007f70adcd4ccf in lokThreadFunc(void*, void*) () at /lib64/liblibreofficekitgtk.so
#1  0x00007f711363b29c in g_thread_pool_thread_proxy (data=<optimized out>) at gthreadpool.c:307
#2  0x00007f711363a900 in g_thread_proxy (data=0x17cd140) at gthread.c:784
#3  0x00007f710e2b9dd5 in start_thread (arg=0x7f70b03ff700) at pthread_create.c:308
#4  0x00007f7112ff394d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113
(gdb) 


Expected results:
password prompt should be shown and document should be opened

Additional info:
documents password is: RedHat1!

Comment 2 Caolan McNamara 2017-12-21 16:25:06 UTC
The crash is in libreoffice's libreofficekit. Whether we can actually prompt and handle passwords is a another thing. But lets not crash anyway.

Comment 3 Caolan McNamara 2017-12-21 16:30:46 UTC
https://gerrit.libreoffice.org/#/c/46923/ is a fix for the specific crash I can reproduce

Comment 12 errata-xmlrpc 2018-04-10 12:04:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0751


Note You need to log in before you can comment on or make changes to this bug.