Bug 15280 - a remote xinetd restart crashes the xinetd server
a remote xinetd restart crashes the xinetd server
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-03 14:17 EDT by Panic
Modified: 2014-03-16 22:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 18:37:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panic 2000-08-03 14:17:05 EDT
Logged in via telnet, su'ed to root.  If I  "/etc/rc.d/init.d/xinetd
restart" remotely like this, xinetd stops, but does not restart.  No
startup or error messages are displayed in /var/log/messages.2 (where
syslog is currently writing).  A restart from the console with someone
connected does not have the same effect -- xinetd is restarted normally in
that case.  The only thing I can think of is that since root is no longer
logged in, the restart script no longer has permission to restart the
service?  No error messages are returned to this effect that I can see.  I
don't care about this working with telnet -- no one should be doing things
that way anyway, but with ssh, if this problem recurs, it could be a
problem.
Comment 1 Panic 2000-08-03 14:42:35 EDT
mdrew -- I've confirmed that this affects only the IA64 6-19-00 release, and
doesn't have any effect on ssh in the i386 pinstripe release (still working on
getting ssh installed on the IA64 6-19-00 release), and probably won't have an
effect on ssh, since it's not an xinetd program.
Comment 2 Panic 2000-08-03 14:43:43 EDT
oh, and doing the restart in the i386 pinstripe release (from a telnet session)
works properly as well and does not disconnect the user.
Comment 3 Trond Eivind Glomsrxd 2000-08-07 18:37:28 EDT
I'll give this to Bill, who does the IA64 stuff.
Comment 4 Bill Nottingham 2000-08-30 16:01:31 EDT
Try this with the 8/25 release; reopen if it still doesn't work.

Note You need to log in before you can comment on or make changes to this bug.