Bug 152833 - w3m browser also crashes on some malformed HTML
w3m browser also crashes on some malformed HTML
Product: Fedora Legacy
Classification: Retired
Component: w3m (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
: Security
Depends On:
  Show dependency treegraph
Reported: 2004-10-29 10:06 EDT by Michal Jaegermann
Modified: 2007-07-26 07:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-26 07:37:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
links_die1.html (1.48 KB, text/html)
2007-04-22 12:52 EDT, Andy Colman
no flags Details

  None (edit)
Description David Lawrence 2005-03-30 18:29:02 EST
Problems described in 
affect w3m browser too.  On 'gallery' samples from
w3m responds with  (there is a pause between the first and the second message)

Out of Memory!  Returning NIL!
Segmentation fault

for 'links_die1.html'. The reaction is the same for w3m-0.3.1-4.7x.1
from RH7.3 and w3m-0.5.1-4 from FC3test so likely this will show up 
in-between too. :-)  Other samples from the same source do not cause
troubles but who knows what else will.

------- Additional Comments From michal@harddata.com 2004-10-30 04:39:55 ----

Later versions of w3m may have _more_ troubles of that sort.  RH bugzilla ref:
See also
for tracking these issues in general.

------- Additional Comments From pekkas@netcore.fi 2005-02-15 06:57:55 ----

FWIW, Red Hat has not released updates on this.

------- Bug moved to this database by dkl@redhat.com 2005-03-30 18:29 -------

This bug previously known as bug 2216 at https://bugzilla.fedora.us/
Originally filed under the Fedora Legacy product and General component.

Unknown priority P3. Setting to default priority "normal".
Unknown platform PC. Setting to default platform "All".
Unknown severity minor. Setting to default severity "normal".
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.

Comment 1 Pekka Savola 2005-11-16 08:20:33 EST
This doesn't seem to be important enough to fix just on its own, so mark it DEFER.
Comment 2 Andy Colman 2007-04-22 12:52:49 EDT
Created attachment 153254 [details]

Note You need to log in before you can comment on or make changes to this bug.