Bug 15285 - ifdown-local executed twice
Summary: ifdown-local executed twice
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-03 19:16 UTC by Andrea Borgia
Modified: 2014-03-17 02:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-18 05:56:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrea Borgia 2000-08-03 19:16:40 UTC
/sbin/ifdown calls
/usr/sbin/usernetctl down (if uid!=0) that calls
/sbin/ifdown that calls
/etc/sysconfig/network-scripts/ifdown-ppp that calls
/etc/sysconfig/network-scripts/ifdown-post that finally calls
/sbin/ifdown-local

also, /etc/ppp/ip-down calls
/etc/sysconfig/network-scripts/ifdown-post that calls
/sbin/ifdown-local

Et voila! ifdown-local ends up being called twice. I found out because both named
wwwoffle complain about duplicate commands (already stopped or already offline).

I found this:
# killing ppp-watch twice in a row causes it to send a SIGKILL to pppd pgrp
kill -TERM $PID > /dev/null 2>&1
# ip-down won't run in this case

Maybe this no longer holds true?

*** Perhaps this no longer holds true? (6.2, initscripts 5.00-1)

Comment 1 Andrea Borgia 2000-08-11 06:39:19 UTC
Still present in Pinstripe

Comment 2 borgia 2000-08-18 05:56:26 UTC
Still present in RC1

Comment 3 Bill Nottingham 2000-08-18 21:38:38 UTC
will be fixed in 5.46-1.


Note You need to log in before you can comment on or make changes to this bug.