Bug 1528575 - The dtb symlink is missing (and needed) on Banana Pi M64 as well
Summary: The dtb symlink is missing (and needed) on Banana Pi M64 as well
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: uboot-tools   
(Show other bugs)
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-22 08:31 UTC by Jan Pazdziora
Modified: 2018-04-09 12:05 UTC (History)
9 users (show)

Fixed In Version: uboot-tools-2018.03-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-09 12:05:05 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Pazdziora 2017-12-22 08:31:24 UTC
Description of problem:

The https://fedoraproject.org/wiki/Common_F27_bugs#aarch64-nonetwork-pine64 says

  When booting the AArch64 disk images on the Pine 64 you will not
  have a network connection. To correct this issue create a symlink
  named 'dtb' pointing to the installed kernel dtb directory
  (dtb-4.13.9-300.fc27.aarch64) and reboot the system.

    cd /boot; ln -sf dtb-4.13.9-300.fc27.aarch64 dtb

On my Banana Pi M64, I had to make the same symlink to make network (eth0) work.  Assuming network is something people want, so either the page on the fedoraproject.org should be amended, or the fedora-arm-installer should be changed to add that symlink.

Version-Release number of selected component (if applicable):

fedora-arm-installer-2.1-1.fc27.noarch
Documentation as of today.

How reproducible:

Deterministic.

Steps to Reproduce:
1. sudo fedora-arm-image-installer --image=/tmp/Fedora-Minimal-27-1.6.aarch64.raw.xz --target=bananapi_m64 --media=/dev/mmcblk0 --selinux=ON --addconsole --norootpass -y
2. Put the SD card to the Banana Pi M64 board SD slot and boot with ethernet connection.

Actual results:

It does not appear to get IP via DHCP (and due to lack of console it virtually not accessible).

Expected results:

Ethernet works and the board gets DHCP and is accessible via sshd.

Additional info:

Comment 1 Jan Pazdziora 2017-12-22 08:35:22 UTC
Checking

https://nullr0ute.com/2017/11/getting-started-with-fedora-on-the-96boards-dragonboard/

it's definitely more than just the Pine 64 listed on the wiki that need the fix.

Comment 2 Jan Pazdziora 2017-12-22 10:20:54 UTC
The wiki page should also mention to keep that dtb symlink in sync with the kernel version after kernel updates, even if for me the kernel update renders networking not working even with the dtb symlink updated -- bug 1528593.

Comment 3 ZeRaler 2017-12-26 19:04:52 UTC
Same problem for Pine64

Comment 4 Peter Robinson 2017-12-28 09:50:37 UTC
It's a known problem, I know the logic needed to fix it, I just need time to code it up and test the fix

Comment 5 Peter Robinson 2017-12-28 09:51:53 UTC
(In reply to Jan Pazdziora from comment #2)
> The wiki page should also mention to keep that dtb symlink in sync with the
> kernel version after kernel updates, even if for me the kernel update
> renders networking not working even with the dtb symlink updated -- bug
> 1528593.

That's a bug, I just need to get the time to work out the exact logic, I know what needs to be done, I just need the time to finish up the fix.


Note You need to log in before you can comment on or make changes to this bug.