Bug 1528583 - Pull container engine system container image failed against authenticated registry
Summary: Pull container engine system container image failed against authenticated reg...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.9.0
Assignee: Giuseppe Scrivano
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-22 09:45 UTC by Gaoyun Pei
Modified: 2018-06-18 18:27 UTC (History)
7 users (show)

Fixed In Version: openshift-ansible-3.9.0-0.20.0.git.0.dce44f0.el7.noarch.rpm
Doc Type: If docs needed, set a value
Doc Text:
pulling of system containers failed from a registry that requires authentication because of the missing support in atomic and Skopeo. With the new feature, it is possible to pull system containers from registries that require authentication.
Clone Of:
Environment:
Last Closed: 2018-06-13 20:13:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 3 Scott Dodson 2018-01-11 15:24:11 UTC
I believe this may be a dupe of an existing bug where atomic doesn't support auth just get and we're waiting on a new build of atomic before we can add auth support.

Comment 4 Giuseppe Scrivano 2018-01-11 16:29:07 UTC
yes indeed.  There are already some PRs to cover this, so I am going to close it and mark as a duplicate

*** This bug has been marked as a duplicate of bug 1505744 ***

Comment 6 Giuseppe Scrivano 2018-01-16 08:51:01 UTC
this is the fix for master:

https://github.com/openshift/openshift-ansible/pull/6646

Comment 7 Gaoyun Pei 2018-01-16 09:51:10 UTC
The proposed PR#6646 was already merged into openshift-ansible-3.9.0-0.20.0.git.0.dce44f0.el7.noarch. Move this bug to ON_QA.

Comment 8 Gaoyun Pei 2018-01-16 09:56:37 UTC
Verify this bug with openshift-ansible-3.9.0-0.20.0.git.0.dce44f0.el7.noarch.rpm.

Enable docker system container in ansible inventory

openshift_docker_use_system_container=true
openshift_docker_systemcontainer_image_override=x.x.x.com:443/openshift3/container-engine:v3.9.0

Run playbook prerequisites.yml, it could pull Container Engine System Container image from an authenticated registry without error.


Note You need to log in before you can comment on or make changes to this bug.