Bug 1528766 - xstatic-jquery-ui-common - bundles file with non-free license
Summary: xstatic-jquery-ui-common - bundles file with non-free license
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-XStatic-jquery-ui
Version: 27
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Radomir Dopieralski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-23 18:08 UTC by Mattias Ellert
Modified: 2018-08-03 20:45 UTC (History)
2 users (show)

Fixed In Version: 1.12.0.1-2 python-XStatic-jquery-ui-1.12.0.1-2.fc27 python-XStatic-jquery-ui-1.12.0.1-2.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-03 19:57:21 UTC


Attachments (Terms of Use)

Description Mattias Ellert 2017-12-23 18:08:10 UTC
Description of problem:

The xstatic-jquery-ui-common package installs a file with a non-free license that can not be distributed by Fedora. The nodejs-jshint package was removed from Fedora due to the license of the jshint.js file. The xstatic-jquery-ui-common package installs copy of this file as:

/usr/share/javascript/jquery_ui/external/jshint.js

This file uses a modified version of the MIT license. The modification makes the license non-free. The modification of the license that makes it non-free is the addition of the following line:

 *   The Software shall be used for Good, not Evil.

Version-Release number of selected component (if applicable):

xstatic-jquery-ui-common-1.10.4.1-8.fc27

Additional info:

https://pagure.io/releng/issue/6659

https://fedoraproject.org/wiki/Packaging:SourceURL?rd=Packaging/SourceURL#When_Upstream_uses_Prohibited_Code

Comment 1 Radomir Dopieralski 2018-06-13 09:30:12 UTC
This file is no longer present in version 1.12.0.1-2.

Comment 2 Mattias Ellert 2018-06-13 11:26:38 UTC
The update to version 1.12 only happened in EPEL 7, Fedora 24, Fedora 25 and Fedora 26.

Fedora 27, Fedora 28 and rawhide still have version 1.10.

Reopening.

Comment 3 Radomir Dopieralski 2018-06-13 11:50:31 UTC
In any case it's fixed in the recent version, they can just upgrade to it.

Comment 4 Matthias Runge 2018-06-13 19:51:42 UTC
The version in f27 and up is older than in f24 to f26. There is no upgrade option then.

Comment 5 Radomir Dopieralski 2018-06-14 12:12:55 UTC
Is there a reason why they use an older version?

Comment 6 Fedora Update System 2018-06-14 13:04:03 UTC
python-XStatic-jquery-ui-1.12.0.1-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f972c1b36e

Comment 7 Mattias Ellert 2018-06-14 13:12:12 UTC
(In reply to Radomir Dopieralski from comment #5)
> Is there a reason why they use an older version?

In the question above. Who are "they"? You are the main admin of the package so you should be the one that should be able to answer this.

According to the git commit logs you are the one who made the updates to version 1.12 in f24-f26 and epel 7 on 2017-04-07. For some reason you did not make the same update to master at the same time (f26 was branched from master 2017-02-28). That f27 and f28 are not using the 1.12 is because they were branched from master that was never updated.

Comment 8 Fedora Update System 2018-06-14 13:23:43 UTC
python-XStatic-jquery-ui-1.12.0.1-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2d2179e7d0

Comment 9 Radomir Dopieralski 2018-06-14 13:26:15 UTC
Thank you Mattias, as you can probably tell, I'm new in this role, and I have no idea what I'm doing. mrunge now helped me to update master, f27 and f28, so it should be all good now.

Comment 10 Fedora Update System 2018-06-14 18:23:36 UTC
python-XStatic-jquery-ui-1.12.0.1-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2d2179e7d0

Comment 11 Fedora Update System 2018-06-14 20:24:44 UTC
python-XStatic-jquery-ui-1.12.0.1-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f972c1b36e

Comment 12 Mattias Ellert 2018-07-20 12:00:37 UTC
Dear maintainer,

these updates have now spent 5 weeks in updates-testing. Is there a reason why they have not yet been pushed to stable? Especially since they are marked as security updates.

Comment 13 Fedora Update System 2018-08-03 19:57:21 UTC
python-XStatic-jquery-ui-1.12.0.1-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2018-08-03 20:45:15 UTC
python-XStatic-jquery-ui-1.12.0.1-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.