Bug 1528917 - 'Guide' button under help returns 404- page not found in RHV
Summary: 'Guide' button under help returns 404- page not found in RHV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ovirt-4.2.2
: ---
Assignee: Greg Sheremeta
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
: 1538052 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-25 07:20 UTC by Michael Burman
Modified: 2019-05-16 13:06 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 17:46:56 UTC
oVirt Team: UX
Target Upstream Version:


Attachments (Terms of Use)
record1 (235.68 KB, application/x-gzip)
2017-12-25 07:20 UTC, Michael Burman
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:48:00 UTC

Description Michael Burman 2017-12-25 07:20:36 UTC
Created attachment 1372068 [details]
record1

Description of problem:
'Guide' button under help returns 404- page not found in RHV

Pressing the 'Guide' button in RHV returns 404.

2017-12-25 09:14:34,638+02 ERROR [org.ovirt.engine.core.utils.servlet.ServletUtils] (default task-12) [] Can't read file '/usr/share/doc/rhvm-doc/manual/en-US/html/Administration_Guide/index.html' for request '/ovirt-engine/docs/manual/en_US/html/Administration_Guide/index.html', will send a 404 error response.

I'm not sure to where it should link me on RHV, on upstream if linking to the oVirt wiki pages.  

Version-Release number of selected component (if applicable):
4.2.0.2-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1. Log in to RHV and press on the 'Guide' button under help administration section.

Comment 1 Tomas Jelinek 2018-01-02 15:06:37 UTC
it should send you to the rhv documentation. But since the documentation is not yet available, you will get 404. When it will be available, we can move this bug to on_qa for verification

Comment 2 Greg Sheremeta 2018-01-03 18:55:54 UTC
Tomas is correct.

It would be nice if we detected the no-docs-installed condition and presented a nicer message.

Comment 3 Lucie Leistnerova 2018-01-16 17:12:17 UTC
Guide link shows Administration guide pages

verified in ovirt-engine-4.2.1.1-0.1.el7.noarch

Comment 4 RHV bug bot 2018-01-18 17:38:45 UTC
INFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[No external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 5 RHV bug bot 2018-01-24 22:07:27 UTC
INFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[No external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 6 RHV bug bot 2018-01-30 11:22:32 UTC
INFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[No external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 7 RHV bug bot 2018-02-02 22:05:07 UTC
INFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[No external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 8 Michael Burman 2018-02-12 06:41:11 UTC
Hi Lucie, 

4.2.1.6-0.1.el7 returns 404 again. Looks like it broken again..

Comment 9 Lucie Leistnerova 2018-02-14 07:35:46 UTC
All documentation is now broken, will be fixed in 4.2.2 as Greg changed. 
Michael, thank you for noticing.

Comment 10 RHV bug bot 2018-02-16 16:24:23 UTC
INFO: Bug status (ON_QA) wasn't changed but the folowing should be fixed:

[No external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 11 Lucie Leistnerova 2018-02-20 10:52:48 UTC
Documentation is available, Guide link works again.

verified in ovirt-engine-dwh-4.2.2-1.el7ev.noarch

Comment 12 RHV bug bot 2018-03-16 15:01:51 UTC
INFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[No external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 13 Greg Sheremeta 2018-04-10 17:28:11 UTC
*** Bug 1538052 has been marked as a duplicate of this bug. ***

Comment 17 errata-xmlrpc 2018-05-15 17:46:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 18 Franta Kust 2019-05-16 13:06:01 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.