Bug 1529493 - [Docs][RFE][VMM] Document Multiple queue NICs feature
Summary: [Docs][RFE][VMM] Document Multiple queue NICs feature
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.2.3
Hardware: All
OS: All
medium
high
Target Milestone: ovirt-4.2.7
: ---
Assignee: Emma Heftman
QA Contact: Alona Kaplan
URL:
Whiteboard: docs-accepted
: 1530032 (view as bug list)
Depends On: 821493 1574771
Blocks: 1541529
TreeView+ depends on / blocked
 
Reported: 2017-12-28 11:31 UTC by Daniele
Modified: 2020-08-03 15:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-12 12:11:48 UTC
oVirt Team: Network
Target Upstream Version:
eheftman: needinfo-
lsvaty: testing_plan_complete-


Attachments (Terms of Use)

Description Daniele 2017-12-28 11:31:34 UTC
Description of problem:
The bug 821493 (https://bugzilla.redhat.com/show_bug.cgi?id=821493#c19) has been closed, but I can not find references to this feature in the official docs, even though there is a "requires_doc_text" tag on it. 
Banca d'Italia has asked about this feature and all I could link to was this BugZilla comment.

Comment 2 Lucy Bopf 2018-01-16 01:55:38 UTC
*** Bug 1530032 has been marked as a duplicate of this bug. ***

Comment 4 Dan Kenigsberg 2018-04-29 15:58:46 UTC
This request affects all currently-supported version. Let us fix it in a 4.2

Comment 5 Lucy Bopf 2018-06-12 03:42:48 UTC
Accepting into 4.2.4 (z1) program and assigning to Emma for review.

Comment 6 Emma Heftman 2018-06-12 07:50:07 UTC
Hi Dan
I'm documenting this feature and I have a few questions.

You wrote:

An administrator can define a new custom property called "queues" for vNIC profiles.

  engine-config -s "CustomDeviceProperties={type=interface;prop={<other-nic-properties;>queues=[1-9][0-9]*}}"

Where <other-nic-properties;> is a semicolon-separated list of prexisting custom properties of nics.

A user can then set it to the number of queues he or she would like to allocate 
to a vNIC using this profile, instead of the default single queue. For best
performance, use the number of vCPUs. 
1. Please explain exactly what values they should enter here: [1-9][0-9]
In other words, i.e. is the first value the ID of the CPU and the second the number of queues for that vCPU?

2. 
"Note that each queue consumes about 100KB
of host memory, so a non-default values only when the number of queues is a
true bottle neck, such as when a multicore VM is expected to communicate with
other VMs on the same host."


What did you mean by" a nonnon-default values only when the number of queues is a
true bottle neck, such as when a multicore VM is expected to communicate with
other VMs on the same host." 

and what should the user do with this information. Can this knowledge help him to configure the custom property more accurately?
Can it help him to decide whether or not it is relvant to configure the custom property in the first place?

3. Do you expect someone to configure this property immediately after installing the system, i.e. whenever they install the virtio-net driver we should immediately tell them to configure this property?
or
Is this something that they should only tweak if they are experiencing performance issues?
If the latter is the case, what indication would they have that their performance issues could be mitigated by configuring this property?

Thanks!
Emma

Comment 8 Emma Heftman 2018-09-04 13:09:53 UTC
This feature has now been replaced by a check box in the UI that automatically sets the value to 4.

Dan, is still necessary to explain how to change the value manually?


Note You need to log in before you can comment on or make changes to this bug.