Bug 15295 - backspace/del (+other keymap) issues in single-user mode.
backspace/del (+other keymap) issues in single-user mode.
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Winston gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-03 15:57 EDT by Pekka Savola
Modified: 2014-03-16 22:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-10 11:12:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2000-08-03 15:57:21 EDT
[I wonder which component these would really belong to; probably bash/setup
related too? -- feel free to relocate ]

I rebooted beta5 to single-user mode.  I noticed the following:

- del generates '~', backspace works.
- keyboard layouts haven't been loaded so keyboard setup is funny
(this is intended behaviour AFAIK, but it would be nice to have this fixed
since it can be pretty frustrating to search for some special chars if you
don't know how to load the keymap)

Running 'fdisk', more weirdness occurs (these are probably connected, so
I'm not filing two reports):

- del generates '/^[[3~' on screen
- backspace generates '^[[3~', and some other chars too
- this happens with installer's fdisk too, IIRC.
- 'dve' which didn't work in stock single user mode shell, seem to work here(!)

Running 'exit' causes the boot process to continue to multiuser mode, not
reboot.  I'm not sure if this was how it was previously.  Is this intended
behaviour?
Comment 1 Glen Foster 2000-08-04 11:28:41 EDT
This defect is considered MUST-FIX for Winston Gold-release
Comment 2 Bill Nottingham 2000-08-04 16:21:47 EDT
This has been fixed in the installer; it should dump
the keymap to a place where it can be loaded.
Comment 3 Pekka Savola 2000-08-10 11:06:05 EDT
Is this intended to be fixed outside installer context too? 

I didn't check this in the installer, but this happens just as before if you do
'linux single'  (RC1).
Comment 4 Bill Nottingham 2000-08-10 11:10:38 EDT
It actually didn't get fixed in the installer, as it didn't
work right.

What you can do is, once the keymap is loaded:

dumpkeys > /etc/sysconfig/console/default.kmap

Then things should work.

Note You need to log in before you can comment on or make changes to this bug.