Bug 152956 - NFS-Mount fails after update to util-linux-2.12a-21
NFS-Mount fails after update to util-linux-2.12a-21
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
: 136592 153762 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-31 06:38 EST by Frank Wittig
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-04 18:50:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes nfs mounts to rollback correctly (1.47 KB, patch)
2005-03-31 17:04 EST, Steve Dickson
no flags Details | Diff

  None (edit)
Description Frank Wittig 2005-03-31 06:38:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
After updating util-linux to version util-linux-2.12a-21 on the clients mounting NFS-shares from the server (rh7.2) fails with following output:

Mar 31 12:34:10 scheitan automount[5696]: mount(nfs): nfs: mount failure gargantua:/mnt/md0/home on /automount/home
Mar 31 12:34:10 scheitan automount[5696]: failed to mount /automount/home
Mar 31 12:34:13 scheitan automount[5698]: >> mount to NFS server 'gargantua' failed: server is down.

There are no other log messages nor messages in the server's logs.

Shared which were mounted before the update were usable but mounting additional shares failed.
Reboot of client/server didn't change anything.

rpcinfo and showmount returned normal autput as expacted. (showed available nfs ports and all exported dirs)

After rollback to version util-linux-2.12a-19 everything is fine.

Version-Release number of selected component (if applicable):
util-linux-2.12a-21

How reproducible:
Always

Steps to Reproduce:
1. update util-linux to version 2.12a-19
2. try to mount NFS by UDP
3. read error message ;-)

Actual Results:  NFS was not mountable

Expected Results:  NFS share should have been mounted

Additional info:
Comment 1 Tom Hughes 2005-03-31 07:22:39 EST
UDP mounts do work, but you need to use -udp explicitly as the default seems to
have changed to TCP.
Comment 2 Frank Wittig 2005-03-31 08:05:02 EST
Adding udp option to my autofs config did it.
But changing default options in such minor version changes is very dangerous, I
think. (Some sort of pseudo bug ;-))
Comment 3 Petr Baudis 2005-03-31 08:35:01 EST
I have to agree. It has burnt us pretty nastily, our FC3 installations stopping
to work randomly. Well, nothing against changing the default, but it should fall
back to udp if tcp fails. I guess this can break a lot of network deployments.
Comment 4 Petr Baudis 2005-03-31 08:37:54 EST
(FWIW, now I see this is a dupe to bug 150775.)
Comment 5 Karel Zak 2005-03-31 09:22:36 EST
Frank, please don't CLOSE this bug anymore.... it's important regression problem.
Comment 6 alvin 2005-03-31 10:55:12 EST
The error message I got from mount was mount to NFS server 'bfs' failed: server
is down.

This had me really confused for a while. If you cannot fail back to the old
default the error message should at least allude to a possible solution.
Somthing like "TCP mount failed.

One of the people here found that SUSE seems to deal with things more cleanly.
the SUSE mounter complained about TCP mounting but went on to use UDP.
Comment 7 Steve Dickson 2005-03-31 17:04:44 EST
Created attachment 112551 [details]
Patch that fixes nfs mounts to rollback correctly

The rpm and srpm that contains this patch is available
at http://people.redhat.com/steved/bz152956
Comment 8 Michal Jaegermann 2005-03-31 21:21:43 EST
This is really a duplicate of #149798 which still lingers.  Only in February
I did not check that it affects not only x86_64 and kind of forgot about the
issue.
Comment 9 Ralph Loader 2005-03-31 22:47:25 EST
'man 5 nfs' still claims that UDP is the default, by the way.
Comment 10 Dan Naughton 2005-04-01 11:27:40 EST
I tried the version util-linux-2.12a-22 from
http://people.redhat.com/steved/bz152956/ and it seems to work well.
Comment 11 Steve Dickson 2005-04-01 13:34:02 EST
*** Bug 147017 has been marked as a duplicate of this bug. ***
Comment 12 Steve Dickson 2005-04-01 14:28:04 EST
*** Bug 136592 has been marked as a duplicate of this bug. ***
Comment 13 Paul Dickson 2005-04-02 08:40:25 EST
(In reply to comment #10)
> I tried the version util-linux-2.12a-22 from
> http://people.redhat.com/steved/bz152956/ and it seems to work well.

I also tried util-linux-2.12a-22 from the above and it resolves my problems.

This should be pushed out to the updates ASAP.  The latest updates contains an
X.org update and reboots will be much more common (and hitting this problem).  I
had to trace this problem back via my yum.log entries.

Thanks for the effort.
Comment 14 Karel Zak 2005-04-05 14:34:58 EDT
*** Bug 153762 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.