Bug 15296 - RFE: Upgrading a live system (without booting first)
Summary: RFE: Upgrading a live system (without booting first)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-03 20:02 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 19:53:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-08-03 20:02:17 UTC
This is an important issue that should be handled in the future, say 7.1
or 7.2.

I think Red Hat Linux definitely needs some tools to upgrade a live
system.  The main reason for this is that you can do it remotely.  I can't
see anything more annoying than having to walk through every Linux
workstation / server and perform the upgrade w/ CD-ROM or bootdisk,
when I just as well could do it via SSH (in the future? :).

Compare this with the upgradeibility of e.g. FreeBSD (cvsup, make world),
and Linux has still ways to go. :-/

Actually, in Pinstripe, you _could_ do 'anaconda --method upgrade', but
it'll die:

you're running me on a live system! that's incredibly stupid.

Tools like AutoRPM aren't enough, because there will always be some
dependencies missing, pretty interesting packages added, problems with
packages that may need heavy scripting/tweaking (like kernel)  etc.

Combined with a tool to handle all those .rpm{save,orig} files (merging
the configurations where needed), we'd be in heaven :)

Comment 1 Pekka Savola 2000-08-03 20:02:57 UTC
Certainly not for this release yet :)



Comment 2 Michael Fulbright 2001-04-11 19:53:01 UTC
up2date will do most of this now.


Note You need to log in before you can comment on or make changes to this bug.