Bug 152973 - PHP should handle files with .phps extension correct
PHP should handle files with .phps extension correct
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On: 153068
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-31 10:32 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 5.0.4-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-12 04:46:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-03-31 10:32:17 EST
Description of problem:
PHP should handle files with .phps extension correct.

Version-Release number of selected component (if applicable):
php-5.0.3-5

Actual results / Expected results:
--- php.conf       2004-11-10 12:10:24.000000000 +0100
+++ php.conf.rsc   2005-02-28 16:10:18.000000000 +0100
@@ -12,6 +12,11 @@
 AddType text/html .php

 #
+# Cause the PHP interpreter to handle files with a .phps extension.
+#
+AddType application/x-httpd-php-source .phps
+
+#
 # Add index.php to the list of files that will be served as directory
 # indexes.
 #
Comment 1 Robert Scheck 2005-04-03 09:32:14 EDT
Thank you for checking in the enhancement into Core CVS, but why don't you enable
the .phps extension per default?!
Comment 2 Joe Orton 2005-04-03 09:42:20 EDT
Oh, just because it wasn't enabled by default before.
Comment 3 Joe Orton 2005-04-12 04:46:14 EDT
...which I think is OK.  It's not that common to want this, I think.

Note You need to log in before you can comment on or make changes to this bug.