Bug 153 - Info re: man.conf location/name is incorrect w.r.t. source
Info re: man.conf location/name is incorrect w.r.t. source
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
5.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-20 17:32 EST by forrest
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-02-12 11:45:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description forrest 1998-11-20 17:32:29 EST
The man-1.5f-1 package seems like it might have a problem.
I was having a problem with man so I fetched the source
(1.5f-1 is right for 5.2 right?)  The INSTALL indicates that
the config file has moved, but it says the new location is
"/etc/man.conf" whereas the actual file installed from the
binary package is "/etc/man.config".  Neither of which
matters though because, as configured, the source builds
a man that want's the configuration file in
"/usr/lib/man.conf".

What started this all is a problem I had with a substitute
shell that has built-ins for common commands (like "cat")
that are dynamically linked.  Since setgid makes
LD_LIBRARY_PATH settings invalid, I was hoping to override
the "cat" usage via the configuration file.  As it turns out
that wouldn't have helped anyway because of line 490 of
man.c where "cat" is hardcoded without reference to the
environment variable "CAT".  Perhaps line 490 should be
replaced with:


          char *cat = getval("CAT");
          sprintf (eos(buf), "%s %s", cat ? cat : "cat",
file);

That's all.
Comment 1 Mike Maher 1999-02-12 11:45:59 EST
This first part of the question seems to be untrue as compared to the
src/man-config.c file:
char *configuration_file = "[no configuration file]";

char *default_config_files[] = {
     CONFIG_FILE,               /* compiled-in default */
     "/usr/lib/man.config", "/usr/lib/man.conf",
     "/", "/etc/man.conf",
     "/usr/share/misc/man.config", "/usr/share/misc/man.conf"
};

Just in case however, the order has been changed parse /etc/man.config
first

The CAT patch was added as well.

Note You need to log in before you can comment on or make changes to this bug.