Bug 15300 - RFE: comps: way to include classes before they are defined
RFE: comps: way to include classes before they are defined
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Michael Fulbright
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-03 16:36 EDT by Pekka Savola
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-17 11:53:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2000-08-03 16:36:37 EDT
As it is, you have to define the comps file classes _before_ you use them.

The algorithm should be expanded so that you could also define them later
in the file.

The reason: the order classes are defined in comps file defines the order
they're shown in the installer.  If the algorithm were to be reworked you
could do something like:

----
1 base {
...
}

1 Our Server {
 @ Development
 @ ...
 ...
}

...

0 Development {
...
}
----

Now, you have to define the classes you want in 'Our Server' one by one (if
you want it to be the first entry in the installer).
Comment 1 Pekka Savola 2000-08-03 16:37:13 EDT
Not for 7.0 :)

Comment 2 Michael Fulbright 2002-05-01 12:23:53 EDT
We're going to rethink the comps file.
Comment 3 Michael Fulbright 2002-07-17 11:53:35 EDT
We've made some changes to the comp file format that should address this issue.
Comment 4 Mike McLean 2002-08-01 11:37:09 EDT
The new comps file format does allow control of the order that package groups
appear.
  <grouphierarchy>
    <category name="Desktops">
      <subcategory>base-x</subcategory>
      <subcategory>gnome-desktop</subcategory>
      <subcategory>kde-desktop</subcategory>
    </category>
    <category name="Applications">
      <subcategory>editors</subcategory>
    ...
CLOSING->RAWHIDE
Comment 5 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.