Bug 1530191 - tempest scenario 'test_hotplug_nic' fails
Summary: tempest scenario 'test_hotplug_nic' fails
Keywords:
Status: CLOSED DUPLICATE of bug 1525520
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: 12.0 (Pike)
Assignee: Assaf Muller
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-02 08:55 UTC by Arie Bregman
Modified: 2019-09-09 15:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-15 16:42:03 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Arie Bregman 2018-01-02 08:55:54 UTC
Description of problem:

The following test fails whenever RHOSP is deployed with OVN:

tempest.scenario.test_network_basic_ops.TestNetworkBasicOps.test_hotplug_nic

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest/common/utils/__init__.py", line 89, in wrapper
    return f(self, *func_args, **func_kwargs)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/test_network_basic_ops.py", line 499, in test_hotplug_nic
    self.check_public_network_connectivity(should_connect=True)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/test_network_basic_ops.py", line 208, in check_public_network_connectivity
    self.servers, mtu=mtu)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/manager.py", line 583, in check_public_network_connectivity
    mtu=mtu)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/manager.py", line 566, in check_vm_connectivity
    msg=msg)
  File "/usr/lib/python2.7/site-packages/unittest2/case.py", line 678, in assertTrue
    raise self.failureException(msg)
AssertionError: False is not true : Timed out waiting for 10.0.0.220 to become reachable


Version-Release number of selected component (if applicable): Latest OSP 12


How reproducible: 100%


Steps to Reproduce:
1. Deploy RHOSP 12 with OVN
2. Run tempest scenario tests

Comment 2 Daniel Alvarez Sanchez 2018-01-15 16:42:03 UTC
This error is produced when an OVN router is scheduled on a compute node. So when compute nodes don't have external access, ping/ssh a FIP will fail.
Marking it as duplicate of #1525520.
We need to land https://code.engineering.redhat.com/gerrit/#/c/126148/ to get the fix in networking-ovn. The fix in THT is already in: openstack-tripleo-heat-templates-7.0.3-20.el7ost (BZ #1510879)
To fix this bug we need both fixed.

*** This bug has been marked as a duplicate of bug 1525520 ***


Note You need to log in before you can comment on or make changes to this bug.