Bug 1530201 - tempest scenario test_server_connectivity fails
Summary: tempest scenario test_server_connectivity fails
Keywords:
Status: CLOSED DUPLICATE of bug 1525520
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Assaf Muller
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-02 09:05 UTC by Arie Bregman
Modified: 2019-09-09 13:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-15 16:43:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Arie Bregman 2018-01-02 09:05:18 UTC
Description of problem:

The following tests fail every time RHOSP 12 is deployed with OVN:

tempest.scenario.test_network_advanced_server_ops.TestNetworkAdvancedServerOps.test_server_connectivity_rebuild
tempest.scenario.test_network_advanced_server_ops.TestNetworkAdvancedServerOps.test_server_connectivity_stop_start
tempest.scenario.test_network_advanced_server_ops.TestNetworkAdvancedServerOps.test_server_connectivity_suspend_resume
tempest.scenario.test_network_advanced_server_ops.TestNetworkAdvancedServerOps.test_server_connectivity_pause_unpause

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest/common/utils/__init__.py", line 89, in wrapper
    return f(self, *func_args, **func_kwargs)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/test_network_advanced_server_ops.py", line 140, in test_server_connectivity_rebuild
    floating_ip = self._setup_network(server, keypair)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/test_network_advanced_server_ops.py", line 78, in _setup_network
    server, keypair, floating_ip)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/test_network_advanced_server_ops.py", line 102, in _wait_server_status_and_check_network_connectivity
    self._check_network_connectivity(server, keypair, floating_ip)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/test_network_advanced_server_ops.py", line 95, in _check_network_connectivity
    servers=[server])
  File "/usr/lib/python2.7/site-packages/tempest/scenario/manager.py", line 583, in check_public_network_connectivity
    mtu=mtu)
  File "/usr/lib/python2.7/site-packages/tempest/scenario/manager.py", line 566, in check_vm_connectivity
    msg=msg)
  File "/usr/lib/python2.7/site-packages/unittest2/case.py", line 678, in assertTrue
    raise self.failureException(msg)
AssertionError: False is not true : Timed out waiting for 10.0.0.223 to become reachable

Version-Release number of selected component (if applicable): Latest OSP 12


How reproducible: 100%


Steps to Reproduce:
1. Deploy RHOSP 12 with OVN
2. Run tempest scenario tests

Comment 2 Daniel Alvarez Sanchez 2018-01-15 16:43:32 UTC
This error is produced when an OVN router is scheduled on a compute node. So when compute nodes don't have external access, ping/ssh a FIP will fail.
Marking it as duplicate of #1525520.
We need to land https://code.engineering.redhat.com/gerrit/#/c/126148/ to get the fix in networking-ovn. The fix in THT is already in: openstack-tripleo-heat-templates-7.0.3-20.el7ost (BZ #1510879)
To fix this bug we need both fixed.

*** This bug has been marked as a duplicate of bug 1525520 ***

Comment 3 jingzhao 2018-01-31 06:48:15 UTC
*** Bug 1539256 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.