Bug 15305 - problem upgrading
problem upgrading
Status: CLOSED DUPLICATE of bug 14984
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-03 18:20 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-04 15:15:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-08-03 18:20:23 EDT
While attempting a upgrade a dialog notified me of lacking 216M of free
space on my / partition.  I hit Ok and a dialog notifies me of a problem
unmounting /dev/hda3.  The next screen wants me to hit next to continue the
upgrade.  I hit back and a error trace is displayed. Here is the trace.

Traceback (innermost last):
  File "/usr/bin/anaconda", line 426, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/gui.py", line 332, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/gui.py", line 674, in run
    mainloop ()
  File "/var/tmp/gnome-python-root/usr/lib/python1.5/site-packages/gtk.py",
line 2554, in mainloop
    _gtk.gtk_main()
  File "/var/tmp/gnome-python-root/usr/lib/python1.5/site-packages/gtk.py",
line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/gui.py", line 405, in
prevClicked
    self.setScreen (self.currentScreen, self.prevClicked)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/gui.py", line 462, in
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/iw/dependencies_gui.py",
line 57, in getScreen
    self.deps = self.todo.verifyDeps ()
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/todo.py", line 768, in
verifyDeps
    self.fstab.umountFilesystems (self.instPath)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/fstab.py", line 487, in
umountFilesystems
    isys.umount(mntPoint, removeDir = 0)
  File "/usr/lib/anaconda/isys.py", line 116, in umount
    mountCount[what] = mountCount - 1
TypeError: bad operand type(s) for -

Local variables in innermost frame:
what: /mnt/sysimage
removeDir: 0

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I1
sS'tree'
p7
S'/mnt/source'
sS'mntPoint'
p8
S'/mnt/sysimage'
p9
sS'device'
p10
S'hdc'
sS'progressWindow'
p11
Comment 1 Need Real Name 2000-08-03 18:29:14 EDT
I am not sure if this is part of the same bug, but my /var/lib/rpm/packages.rpm
file was mostly wiped out and rpm -qa returns nothing.
Comment 2 Michael Fulbright 2000-08-04 15:15:15 EDT

*** This bug has been marked as a duplicate of 14984 ***

Note You need to log in before you can comment on or make changes to this bug.