Bug 1530548 - Update to lighttpd 1.4.48
Summary: Update to lighttpd 1.4.48
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: lighttpd
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-03 10:28 UTC by David Anderson
Modified: 2018-01-23 19:32 UTC (History)
3 users (show)

Fixed In Version: lighttpd-1.4.48-1.el7 lighttpd-1.4.47-1.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-18 23:32:45 UTC
Type: Bug


Attachments (Terms of Use)

Description David Anderson 2018-01-03 10:28:37 UTC
Description of problem:

I am running the current EPEL 6 version of lighttpd, (1.4.45) but recently, it segfaults a couple of hundred times a day. I cannot report this upstream, because they will just say "update to the current release". But, the current release is not available in EPEL 6. Please can you package the current version?

Version-Release number of selected component (if applicable):

lighttpd-1.4.45-1.el6.x86_64

Comment 1 Gwyn Ciesla 2018-01-03 14:51:40 UTC
I've got an update coming for epel7, but 1.4.48 doesn't like EL-6's older autotools. I'm working on it.

Comment 2 Fedora Update System 2018-01-03 14:52:46 UTC
lighttpd-1.4.48-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-5ac9ee4e7f

Comment 3 Fedora Update System 2018-01-03 21:45:36 UTC
lighttpd-1.4.48-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-5ac9ee4e7f

Comment 4 David Anderson 2018-01-06 12:23:20 UTC
I'm fairly sure that this bug - with a trivial patch - is the cause of the segfault-ing that I'm seeing: https://redmine.lighttpd.net/issues/2822 (having strace-d my lighttpd process and watched it crash a few times, the last request is always one like the one in that bug report).

Any chance that you could add that patch to the current lighttpd build on EL6, if getting 1.4.48 to build isn't an easy problem to fix?

Comment 5 Gwyn Ciesla 2018-01-06 17:40:43 UTC
It would appear that:

A. That patch is already in 1.4.46.

B. I can get 1.4.46 to build on EL-6.

Update incoming, please test.

Comment 6 Fedora Update System 2018-01-06 17:46:01 UTC
lighttpd-1.4.46-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-30b25ee0c6

Comment 7 David Anderson 2018-01-06 18:00:49 UTC
OK - I will install this on Monday (the affected server is live, so Saturday evening is not a great time... though it currently segfaults, it is automatically restarted, so I'll stick with the known problem until Monday!).

Comment 8 David Anderson 2018-01-06 18:03:59 UTC
Though - the 1.4.47 and 1.4.48 changelogs indicate that 1.4.46 introduces 3 regressions (https://www.lighttpd.net/2017/11/11/1.4.48/ , https://www.lighttpd.net/2017/11/11/1.4.48/) - any chance of pulling in the patches for those?

Unless I'm misreading this, as-is, I'll certainly be hit by this (patched in 1.4.47) regression if I try 1.4.46: https://redmine.lighttpd.net/issues/2830

Comment 9 Gwyn Ciesla 2018-01-06 18:12:36 UTC
I didn't get the other 2 bug numbers, just 2830.

I can certainly try. :)

Comment 10 David Anderson 2018-01-06 18:19:01 UTC
This is the other bug that the changelog marks as a regression in 1.4.46: https://redmine.lighttpd.net/issues/2835

The other bug isn't indicated in the changelog, but a quick hunt reveals that it's this one (the patch is in the last-but-one post)
https://redmine.lighttpd.net/boards/2/topics/7686

Comment 11 David Anderson 2018-01-06 18:19:46 UTC
Though... you don't say whether 1.4.47 itself will already compile on EL6? (You mentioned that 1.4.48 is giving trouble).

Comment 12 Gwyn Ciesla 2018-01-06 18:32:32 UTC
1.4.47 wouldn't last I tried, but since learning what I learned in trying to build 1.4.48, it does.  Update incoming with a patch for 2835.

Comment 13 Fedora Update System 2018-01-06 20:26:22 UTC
lighttpd-1.4.47-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-30b25ee0c6

Comment 14 David Anderson 2018-01-09 18:40:27 UTC
Thank you. I've installed this now, and will let you know how it goes.

Comment 15 David Anderson 2018-01-09 18:51:50 UTC
I've not had time to investigate why, but after updating, I could only visit SSL websites. HTTP ones gave connection errors. Rolling back fixed it. Nothing in the logs. netstat indicated it was listening on the same ports/IPs. I will have to try it again later when I have more time and see what else I can find.

Comment 16 David Anderson 2018-01-09 19:44:17 UTC
I've got it up and running now. For reasons I don't understand (nothing in the changelog stands out), I had to uncomment the server.bind option in my lighttpd.conf (with value "0.0.0.0").... whereas, uncommenting that on 1.4.45 resulted in an error that port 80 was already in use. I think lighttpd has changed how it deals with listening on both IPv4 and IPv6 simultaneously - it doesn't seem to be a packaging problem. And I have no idea how common my (heavily customised) config file would be.

Comment 17 David Anderson 2018-01-11 10:29:30 UTC
I can confirm that with 1.4.47, the segfaults that I was getting with 1.4.45 no longer occur.

Comment 18 Gwyn Ciesla 2018-01-11 15:13:04 UTC
Fantastic, thank for your help!

Comment 19 David Anderson 2018-01-12 18:47:21 UTC
I have been hit by this bug/regression, which might hit quite a few people. There is a patch available (the alternative is to re-write your configuration file). I think the patch is in 1.4.48, but clearly isn't in 1.4.47 (which I am running):
https://redmine.lighttpd.net/issues/2830

Comment 20 David Anderson 2018-01-12 18:51:19 UTC
This duplicate says that it was fixed in 1.4.47 - https://redmine.lighttpd.net/issues/2831 . (But as I say, I'm having the problem described; and the work-around in #2830 works for me).

Comment 21 Gwyn Ciesla 2018-01-18 02:36:59 UTC
The patch for 2831 doesn't apply to 1.4.47, and I'm having difficulty finding where it should go.

Comment 22 Fedora Update System 2018-01-18 23:32:45 UTC
lighttpd-1.4.48-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2018-01-23 19:32:07 UTC
lighttpd-1.4.47-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.