Bug 1530611 - Kolla being installed on undercloud by default
Summary: Kolla being installed on undercloud by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Alex Schultz
QA Contact: Artem Hrechanychenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-03 13:39 UTC by Jon Schlueter
Modified: 2018-08-03 18:32 UTC (History)
14 users (show)

Fixed In Version: instack-undercloud-8.1.1-0.20171206155309.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:40:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:41:41 UTC

Description Jon Schlueter 2018-01-03 13:39:08 UTC
Description of problem:

by default undercoud install is attempting to install kolla but not packaged.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. install undercloud
2.
3.

Actual results:

2017-12-20 23:26:41.620 | 2017-12-20 16:20:47,888 INFO: Error: Execution of '/bin/yum -d 0 -e 0 -y install openstack-kolla' returned 1: Error: Nothing to do
2017-12-20 23:26:41.622 | 2017-12-20 16:20:47,889 INFO: Error: /Stage[main]/Tripleo::Profile::Base::Docker_registry/Package[openstack-kolla]/ensure: change from purged to present failed: Execution of '/bin/yum -d 0 -e 0 -y install openstack-kolla' returned 1: Error: Nothing to do

Expected results:

Undercloud install does not attempt to install kolla by default

Additional info:

Comment 2 Alex Schultz 2018-01-03 15:27:26 UTC
This can be disabled by setting enable_container_images_build to false in hiera. https://github.com/openstack/puppet-tripleo/blob/master/manifests/profile/base/docker_registry.pp#L39  We'll probably need to do this downstream.

Comment 3 Alex Schultz 2018-01-03 15:43:05 UTC
Found the downstream patch for this from 12 and ported it forward.

Comment 7 Artem Hrechanychenko 2018-02-05 10:41:05 UTC
VERIFIED

(undercloud) [stack@undercloud-0 ~]$ sudo rpm -qa "instack-undercloud"
instack-undercloud-8.1.1-0.20180117134321.el7ost.noarch

Comment 8 Emilien Macchi 2018-05-17 16:14:24 UTC
To verify it you need to check if openstack-kolla is trying to be installed, just FYI.

Comment 11 errata-xmlrpc 2018-06-27 13:40:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.