Bug 1530612 - undercloud install failing on ironic-staging-drivers
Summary: undercloud install failing on ironic-staging-drivers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic-staging-drivers
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Dmitry Tantsur
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-03 13:44 UTC by Jon Schlueter
Modified: 2018-06-27 13:41 UTC (History)
10 users (show)

Fixed In Version: openstack-ironic-staging-drivers-0.8.1-0.20171128164251.e3cb506.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:40:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1564841 None None None 2018-01-03 15:17:04 UTC
Red Hat Bugzilla 1484363 None CLOSED [RFE] Ironic driver for RHV/oVirt 2019-09-30 10:50:30 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:41:41 UTC

Internal Links: 1484363

Description Jon Schlueter 2018-01-03 13:44:54 UTC
Description of problem:

undercloud failing on missing package ironic-staging-drivers


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install undercloud
2.
3.

Actual results:

2017-12-20 23:26:41.603 | 2017-12-20 16:20:02,526 INFO: Error: Execution of '/bin/yum -d 0 -e 0 -y install openstack-ironic-staging-drivers' returned 1: Error: Nothing to do
2017-12-20 23:26:41.605 | 2017-12-20 16:20:02,527 INFO: Error: /Stage[main]/Ironic::Drivers::Staging/Package[ironic-staging-drivers]/ensure: change from purged to present failed: Execution of '/bin/yum -d 0 -e 0 -y install openstack-ironic-staging-drivers' returned 1: Error: Nothing to do

Expected results:

Undercloud installs.

Additional info:

Comment 2 Ramon Acedo 2018-01-03 14:48:18 UTC
Ironic staging drivers is a requirement for the RHV/oVirt Ironic driver: https://bugzilla.redhat.com/show_bug.cgi?id=1484363#c2

We need to make sure it's there.

Comment 3 Bob Fournier 2018-01-03 15:05:26 UTC
This is a request to add the openstack-ironic-staging-drivers package to OSP.

Comment 8 Alexander Chuzhoy 2018-05-07 20:46:15 UTC
Verified:

Environment:
openstack-ironic-staging-drivers-0.9.0-4.el7ost.noarch



Undercloud was deployed successfully.

(undercloud) [stack@undercloud ~]$ rpm -q openstack-ironic-staging-drivers
openstack-ironic-staging-drivers-0.9.0-4.el7ost.noarch

Comment 10 errata-xmlrpc 2018-06-27 13:40:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.