Bug 153064 - USB Sound card seems to change address when unplugged/plugged
USB Sound card seems to change address when unplugged/plugged
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ALSA
  Show dependency treegraph
 
Reported: 2005-04-01 03:20 EST by Christian Schaller
Modified: 2015-01-04 17:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 02:53:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Schaller 2005-04-01 03:20:47 EST
I recently bought a Sound Blaster Audigy2 NX USB sound card for my laptop.
Noticed that if I unplug it, then plug it back in it seems it is getting
assigned a new address. So it means that when I plugin it in the first time it
ends up as hw:2,0
 but if I plug it out and plug it back in it becomes hw:3,0 afaict.

I talked to David Zeuthen at HAL is getting USB soundcard support in FC4 (sorta)
so I don't know if the problem will be solved through HAL and friends or if it
can/should be addressed within the confines of hotplug.
Comment 1 Dave Jones 2005-07-15 15:21:52 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 Dave Jones 2005-12-07 02:53:00 EST
This bug has been mass-closed along with all other bugs that
have been in NEEDINFO state for several months.

Due to the large volume of inactive bugs in bugzilla, this
is the only method we have of cleaning out stale bug reports
where the reporter has disappeared.

If you can reproduce this bug with current FC3 updates, please
reopen this bug.

If you are not the reporter, you can add a comment requesting
it be reopened, and someone will get to it asap.

If you are not the reporter, but can reproduce this problem against
FC4, please open a new bug.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.