Bug 1530679 - please build orangefs for EPEL
Summary: please build orangefs for EPEL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: orangefs
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Brandenburg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-03 16:04 UTC by Dave Love
Modified: 2018-01-30 16:51 UTC (History)
1 user (show)

Fixed In Version: orangefs-2.9.7-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-30 16:51:46 UTC
Type: Bug


Attachments (Terms of Use)
OrangeFS WebDAV and JNI client support (6.68 KB, patch)
2018-01-04 19:54 UTC, Martin Brandenburg
no flags Details | Diff

Description Dave Love 2018-01-03 16:04:16 UTC
[Bugzilla won't let me raise this for EPEL.]

There currently only seems to be an orangefs package for rawhide.
I'd have expected it for other releases, but it should probably be
built for EPEL, at least -- the 2.9.7 release notes say it's there.

Comment 1 Martin Brandenburg 2018-01-03 20:28:14 UTC
(In reply to Dave Love from comment #0)
> [Bugzilla won't let me raise this for EPEL.]
> 
> There currently only seems to be an orangefs package for rawhide.
> I'd have expected it for other releases, but it should probably be
> built for EPEL, at least -- the 2.9.7 release notes say it's there.

Do they really?  They shouldn't.  It says "will also be in EPEL."  Of
course that's future tense, but I have to agree that it's not very
clear.

It is planned anyway.  We have people here who want to use it with JNI
and WebDAV support.  I have done a build for them and have been waiting
for them to confirm that everything works as it should (especially the
JNI bits).  Then they ran into unrelated trouble of their own, plus the
holidays slowed everyone down.

I didn't want to branch EPEL until I had JNI and WebDAV in (and
confirmation that it actually works as intended).  I suppose I could and
possibly should do it the other way though.

I missed Fedora 27, but it should be in Fedora 28.

Comment 2 Dave Love 2018-01-04 15:14:11 UTC
Ah, OK.

I guess I shouldn't have said "release notes" -- I was looking at 2.9.7 under http://www.orangefs.org/, and I suppose that doesn't actually say it's already in EPEL.
I'm not aware of a reason not to build for released Fedora versions, which is what normally happens with new packages, though I'm only interested in EPEL.

[I'm glad the JNI build works somehow; I never figured out the build failure I got.]

Comment 3 Martin Brandenburg 2018-01-04 19:54:40 UTC
Created attachment 1377144 [details]
OrangeFS WebDAV and JNI client support

Comment 4 Martin Brandenburg 2018-01-04 19:55:15 UTC
(In reply to Dave Love from comment #2)
> Ah, OK.
> 
> I guess I shouldn't have said "release notes" -- I was looking at 2.9.7
> under http://www.orangefs.org/, and I suppose that doesn't actually say it's
> already in EPEL.
> I'm not aware of a reason not to build for released Fedora versions, which
> is what normally happens with new packages, though I'm only interested in
> EPEL.
> 
> [I'm glad the JNI build works somehow; I never figured out the build failure
> I got.]

Well, I must admit some ignorance as to Fedora procedures, but my
understanding is that it was accepted too late for 27.

JNI was a pain, but it seems to build now.  I scrapped our upstream
build process in favor of the %mvn_build macro.  But I don't know enough 
about it to test that everything works as it should, so I wanted to hold
off until the people who do can test it.

I was going to send the patch to the Fedora packaging mailing list for
review after our people test it, but I might as well attach what I have
here now.

Comment 5 Fedora Update System 2018-01-09 16:54:47 UTC
orangefs-2.9.7-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-be24fc1985

Comment 6 Martin Brandenburg 2018-01-09 17:01:43 UTC
I have gone ahead and submitted the package to EPEL without JNI and
WebDAV.

JNI support will take some work upstream, and WebDAV would benefit from
some work upstream.  Both would have to be built manually to get around
assumptions in upstream build scripts (see comment about WebDAV in
attached patch).  These are still on my to-do list.

Comment 7 Fedora Update System 2018-01-09 17:49:08 UTC
orangefs-2.9.7-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-353f98516b

Comment 8 Fedora Update System 2018-01-10 14:06:53 UTC
orangefs-2.9.7-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-be24fc1985

Comment 9 Fedora Update System 2018-01-10 16:14:51 UTC
orangefs-2.9.7-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-353f98516b

Comment 10 Fedora Update System 2018-01-23 21:44:31 UTC
orangefs-2.9.7-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2018-01-30 16:51:46 UTC
orangefs-2.9.7-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.