Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
This project is now read‑only. Starting Monday, February 2, please use https://ibm-ceph.atlassian.net/ for all bug tracking management.

Bug 1530801

Summary: Swift post via RGW ends up with random 500 errors
Product: [Red Hat Storage] Red Hat Ceph Storage Reporter: Ken Dreyer (Red Hat) <kdreyer>
Component: RGWAssignee: Adam C. Emerson <aemerson>
Status: CLOSED ERRATA QA Contact: Tejas <tchandra>
Severity: high Docs Contact:
Priority: high    
Version: 3.0CC: aemerson, bschmaus, cbodley, ceph-eng-bugs, ceph-qe-bugs, hnallurv, kbader, kdreyer, mbenjamin, mhackett, mwatts, owasserm, sweil, tserlin, vumrao
Target Milestone: z1   
Target Release: 3.0   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: RHEL: ceph-12.2.1-41.el7cp Ubuntu: ceph_12.2.1-43redhat1xenial Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1491739 Environment:
Last Closed: 2018-03-08 15:52:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1491739    

Comment 2 Adam C. Emerson 2018-01-05 22:20:50 UTC
For testing purposes, we are working on the assumption that this bug is caused by cache invalidation notifies failing to propagate to all machines under heavy load

Thus, as with the other bug (as discussed before with me and Eric) run the cluster under heavy enough load with multiple gateways until the log starts showing failures to propagate cache. Have the gateways update bucket metadata. Eventually you should be able to provoke the behavior where one node has failed to have its cache updated and responds with a 500 error.

The fix should make that not happen

Comment 10 errata-xmlrpc 2018-03-08 15:52:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0474