Bug 1530967 - Change categories of "Guest Operating system management by VIX API" in v2v man page
Summary: Change categories of "Guest Operating system management by VIX API" in v2v ma...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.5
Hardware: x86_64
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard: V2V
Depends On: 1621895
Blocks: 1657652
TreeView+ depends on / blocked
 
Reported: 2018-01-04 10:26 UTC by mxie@redhat.com
Modified: 2019-08-06 12:44 UTC (History)
5 users (show)

Fixed In Version: libguestfs-1.40.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1657652 (view as bug list)
Environment:
Last Closed: 2019-08-06 12:44:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (111.15 KB, image/png)
2018-01-04 10:26 UTC, mxie@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:2096 None None None 2019-08-06 12:44:35 UTC

Description mxie@redhat.com 2018-01-04 10:26:17 UTC
Created attachment 1376781 [details]
screenshot

Description of problem:
Change categories of "Guest Operating system management by VIX API" in v2v man page


Version-Release number of selected component (if applicable):
libguestfs-1.36.10-4.el7.x86_64
virt-v2v-1.36.10-4.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1.Check "VCENTER: NON-ADMINISTRATOR ROLE" info in v2v man page

 VCENTER: NON-ADMINISTRATOR ROLE
       Instead of using the vCenter Administrator role, you can create a
       custom non-administrator role to perform the conversion.  You will
       however need to give it a minimum set of permissions as follows:

       1.  Create a custom role in vCenter.

       2.  Enable (check) the following objects:

            Datastore:
             - Browse datastore
             - Low level file operations

            Sessions:
             - Validate session

            Virtual Machine:
              Provisioning:
                - Allow disk access
                - Allow read-only disk access
                - Guest Operating system management by VIX API


2.Try to add a role with setting above permission for vcenter6.5 server in vsphere client web, but found  "Guest Operating system management by VIX API " actually belongs to  Virtual Machine->Interaction,please refer to screenshot

Log into vsphere client web with administrator account -> open 'Home'interface -> select "role" -> click "+" -> select related permission

Actual results:
As above description

Expected results:
Change categories of "Guest Operating system management by VIX API" from "Provisioning" to "Interaction" in v2v man page

Additional info:
Vcenter6.0 has same categories of "Guest Operating system management by VIX API" in vsphere client web

Comment 2 Red Hat Bugzilla Rules Engine 2018-07-23 13:21:09 UTC
Development Management has reviewed and declined this request. You may appeal this decision by reopening this request.

Comment 3 Richard W.M. Jones 2018-07-23 13:22:31 UTC
Oops.

Comment 4 Pino Toscano 2018-12-13 13:59:44 UTC
Patch posted:
https://www.redhat.com/archives/libguestfs/2018-December/msg00117.html

Comment 5 Pino Toscano 2018-12-13 15:40:58 UTC
Fixed upstream with
https://github.com/libguestfs/libguestfs/commit/37955f14aa628bedbe0c06bddb5f8fa4f508cc62
which is in libguestfs >= 1.39.15.

Comment 6 Pino Toscano 2019-01-17 11:58:18 UTC
This bug will be fixed by the rebase scheduled for RHEL 7.7, see bug 1621895.

Comment 8 zhoujunqin 2019-03-07 03:25:26 UTC
I can reproduce this issue with package:
virt-v2v-1.38.2-12.el7.x86_64
libguestfs-1.38.2-12.el7.x86_64

Then try to verify this bug with new build:
virt-v2v-1.40.2-1.el7.x86_64
libguestfs-1.40.2-1.el7.x86_64

1.Check "VCENTER: NON-ADMINISTRATOR ROLE" info in v2v man page
# man virt-v2v-input-vmware
...
   vCenter: Non-administrator role
       Instead of using the vCenter Administrator role, you can create a custom non-administrator role to perform the conversion.  You will however need to give it a minimum set of permissions as follows
       (using VMware vCenter 6.5):

       1.  Create a custom role in vCenter.

       2.  Enable (check) the following objects:

            Datastore:
             - Browse datastore
             - Low level file operations

            Sessions:
             - Validate session

            Virtual Machine:
              Interaction:
                - Guest operating system management by VIX API
              Provisioning:
                - Allow disk access
                - Allow read-only disk access
Result:
    The Categories of "Guest Operating system management by VIX API" is correct in virt-v2v-input-vmware man page now

Comment 9 zhoujunqin 2019-04-12 06:45:54 UTC
Verify this bug with latest build:
libguestfs-1.40.2-2.el7.x86_64
virt-v2v-1.40.2-2.el7.x86_64
libvirt-4.5.0-11.el7.x86_64
qemu-kvm-rhev-2.12.0-26.el7.x86_64

Step:

1.Check "VCENTER: NON-ADMINISTRATOR ROLE" info in v2v man page
# man virt-v2v-input-vmware
...
 Instead of using the vCenter Administrator role, you can create a
       custom non-administrator role to perform the conversion.  You will
       however need to give it a minimum set of permissions as follows (using
       VMware vCenter 6.5):

       1.  Create a custom role in vCenter.

       2.  Enable (check) the following objects:

            Datastore:
             - Browse datastore
             - Low level file operations

            Sessions:
             - Validate session

            Virtual Machine:
              Interaction:
                - Guest operating system management by VIX API
              Provisioning:
                - Allow disk access
                - Allow read-only disk access

Result: 
The Categories of "Guest Operating system management by VIX API" is correct in v2v man page now, so move the bug from ON_QA to VERIFIED

Comment 11 errata-xmlrpc 2019-08-06 12:44:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2096


Note You need to log in before you can comment on or make changes to this bug.