Bug 1531 - Static routes to host does not work on 2.2 kernel
Summary: Static routes to host does not work on 2.2 kernel
Status: CLOSED DUPLICATE of bug 1528
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
(Show other bugs)
Version: 5.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-16 16:58 UTC by Jan "Yenya" Kasprzak
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-16 21:44:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan "Yenya" Kasprzak 1999-03-16 16:58:54 UTC
When you enter the static host route to the linuxconf,
the ifup-routes tries to add this route using

route `linuxconf --hint routing <interface>`,

which expands to

route add -host <addr> gw <addr> netmask 255.255.255.255,

which the "route" command (from the updates/5.2/2.2-kernel)
does not like. The "linuxconf --hint routing eth0" should
print "add -host <addr> gw <addr>" for host static routes
(without the "netmask <netmask>").

Comment 1 Bill Nottingham 1999-03-16 21:44:59 UTC
*** This bug has been marked as a duplicate of 1528 ***


Note You need to log in before you can comment on or make changes to this bug.