Bug 15310 - "BUG IN DYNAMIC LINKER ld.so" when running client executable
"BUG IN DYNAMIC LINKER ld.so" when running client executable
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: binutils (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-03 19:04 EDT by Jarod Wilson
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-03 19:48:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarod Wilson 2000-08-03 19:04:23 EDT
Client has provided a RPM built against a WInston Beta-3 system. When
trying to run on
Pinstripe we get the following:
  BUG IN DYNAMIC LINKER ld.so: dl-version.c: 217: _dl_check_map_versions:
Assertion `needed != ((void *)0)' failed!

Here is the output from "LD_DEBUG=files"

19644:
19644:  file=libmysqlclient.so.9;  needed by ./wiz2serv
19644:  file=libmysqlclient.so.9;  generating link map
19644:    dynamic: 0x40052e24  base: 0x40029000   size: 0x0002a140
19644:      entry: 0x4002f410  phdr: 0x40029034  phnum:          3
19644:
19644:
19644:  file=libm.so.6;  needed by ./wiz2serv
19644:  file=libm.so.6;  generating link map
19644:    dynamic: 0x40073280  base: 0x40054000   size: 0x0001f34c
19644:      entry: 0x40058a00  phdr: 0x40054034  phnum:          5
19644:
19644:
19644:  file=libcrypt.so.1;  needed by ./wiz2serv
19644:  file=libcrypt.so.1;  generating link map
19644:    dynamic: 0x40079dac  base: 0x40074000   size: 0x0002cf3c
19644:      entry: 0x40074fa0  phdr: 0x40074034  phnum:          5
19644:
19644:
19644:  file=libc.so.6;  needed by ./wiz2serv
19644:  file=libc.so.6;  generating link map
19644:    dynamic: 0x401b62b8  base: 0x400a1000   size: 0x00119288
19644:      entry: 0x400bc420  phdr: 0x400a1034  phnum:          5
19644:
19644:
19644:  file=libnsl.so.1;  needed by /usr/lib/mysql/libmysqlclient.so.9
19644:  file=libnsl.so.1;  generating link map
19644:    dynamic: 0x401ce900  base: 0x401bb000   size: 0x00015b20
19644:      entry: 0x401beee0  phdr: 0x401bb034  phnum:          5
19644:
19644:
19644:  file=libz.so.1;  needed by /usr/lib/mysql/libmysqlclient.so.9
19644:  file=libz.so.1;  generating link map
19644:    dynamic: 0x401de290  base: 0x401d1000   size: 0x0000d350
19644:      entry: 0x401d2e30  phdr: 0x401d1034  phnum:          3
19644:
BUG IN DYNAMIC LINKER ld.so: dl-version.c: 217: _dl_check_map_versions:
Assertion `needed != ((void *)0)' failed!

The client is trying to get this onto the LACD so timing is very important
here.
Comment 1 Jakub Jelinek 2000-08-03 19:19:47 EDT
Can they reproduce it with binutils from pinstripe?
I found a similar bug report in the archive, H.J.Lu provided a patch
for binutils which should fix it and it seems to be present in pinstripe
binutils
Comment 2 Jarod Wilson 2000-08-03 19:48:04 EDT
Going to try and get the client to do this. The problem is they sit behind a
128k link on the other side of the country - will take them too long to download
pinstripe and best we can via post is 'overnight'. It is already Friday here and
that would make it too late to make LACD deadlines.
Comment 3 Jakub Jelinek 2000-08-25 09:21:56 EDT
If current binutils still generate programs/libraries which trigger the above
assert (well, current glibc is compiled with NDEBUG so the assert won't show up
anyway), please reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.