Bug 153127 - yum failed to create xen guest/var/yum... area
yum failed to create xen guest/var/yum... area
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-01 14:04 EST by John Shakshober
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 02:13:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Shakshober 2005-04-01 14:04:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041115

Description of problem:


Xen failed to create xenU installation.
Traceback (most recent call last):
  File "/usr/bin/yum", line 15, in ?
    yummain.main(sys.argv[1:])

This worked after I manually created /xen/perf1/var/cache/yum/.gpgkeyschecked.yum





Version-Release number of selected component (if applicable):
 yum-2.3.1-1   on  2.6.11-1.1219_FC4xen0 kernel

How reproducible:
Always

Steps to Reproduce:
1.install xen0
2.setup xen perf web site instructions http://fedora.redhat.com/projects/virtualization/
3. failed in the yum install section.
  

Actual Results:  [root@dhcp83-22 shak]# yum --installroot=/xen/perf1 -y groupinstall Base
Traceback (most recent call last):
  File "/usr/bin/yum", line 15, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 51, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 281, in getOptionsConfig
    self.parseCommands() # before we exit check over the base command + args
  File "/usr/share/yum-cli/cli.py", line 339, in parseCommands
    if not self.gpgKeyCheck():
  File "__init__.py", line 1118, in gpgKeyCheck
IOError: [Errno 2] No such file or directory: '/xen/perf1/var/cache/yum/.gpgkeyschecked.yum'
[root@dhcp83-22 shak]# ls -ltr /boot | grep xen
-rw-r--r--  1 root root  143121 Mar 28 16:26 xen.gz
-rw-r--r--  1 root root  373754 Mar 28 16:26 xen-syms
-rw-r--r--  1 root root 1547997 Mar 31 02:11 vmlinuz-2.6.11-1.1219_FC4xen0
-rw-r--r--  1 root root   53066 Mar 31 02:11 config-2.6.11-1.1219_FC4xen0
-rw-r--r--  1 root root  695389 Mar 31 02:11 System.map-2.6.11-1.1219_FC4xen0
-rw-r--r--  1 root root 1179225 Mar 31 02:19 vmlinuz-2.6.11-1.1219_FC4xenU
-rw-r--r--  1 root root   18693 Mar 31 02:19 config-2.6.11-1.1219_FC4xenU
-rw-r--r--  1 root root  526422 Mar 31 02:19 System.map-2.6.11-1.1219_FC4xenU
-rw-r--r--  1 root root 1488454 Mar 31 09:44 initrd-2.6.11-1.1219_FC4xen0.img

Expected Results:  Install should have worked, and did after manually creating the directory

Additional info:
Comment 1 Seth Vidal 2005-04-05 02:13:50 EDT
fixed in cvs, thanks for pointing this one out.

Note You need to log in before you can comment on or make changes to this bug.