Bug 1531927 - lirc_zilog ceased working with kernel 4.14
Summary: lirc_zilog ceased working with kernel 4.14
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-06 17:45 UTC by Warren Sturm
Modified: 2018-05-11 17:45 UTC (History)
19 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-04-27 01:20:11 UTC


Attachments (Terms of Use)
dmesg output after boot with GPF OOPs (97.03 KB, text/plain)
2018-04-12 17:56 UTC, Warren Sturm
no flags Details
Error message for irsend (107 bytes, text/plain)
2018-04-12 17:58 UTC, Warren Sturm
no flags Details
Loaded modules (116 bytes, text/plain)
2018-04-12 17:59 UTC, Warren Sturm
no flags Details
lspci output (3.23 KB, text/plain)
2018-04-12 18:00 UTC, Warren Sturm
no flags Details
dmesg output after rmmod with another OOPs (98.09 KB, text/plain)
2018-04-12 18:02 UTC, Warren Sturm
no flags Details

Description Warren Sturm 2018-01-06 17:45:58 UTC
Description of problem:

With kernel 4.14.* the lirc_zilog module will load but it does not appear that the firmware gets uploaded to it.  It still works in 4.13.16.  Trying to remove it will cause paging errors.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Alec Leamas 2018-01-07 09:43:15 UTC
Hi!

Thanks for reporting. That said, kernel modules is part of kernel, not lirc. Re-assigning

Comment 2 Warren Sturm 2018-02-17 17:34:21 UTC
This is still the case with 4.15.3 kernel

Comment 3 Warren Sturm 2018-04-12 17:56 UTC
Created attachment 1421007 [details]
dmesg output after boot with GPF OOPs

Comment 4 Warren Sturm 2018-04-12 17:58 UTC
Created attachment 1421008 [details]
Error message for irsend

Comment 5 Warren Sturm 2018-04-12 17:59 UTC
Created attachment 1421009 [details]
Loaded modules

Comment 6 Warren Sturm 2018-04-12 18:00 UTC
Created attachment 1421010 [details]
lspci output

Comment 7 Warren Sturm 2018-04-12 18:02 UTC
Created attachment 1421011 [details]
dmesg output after rmmod with another OOPs

I also tried reloading the lirc_zilog module.  After a short time the system froze.

Comment 8 Jeremy Cline 2018-04-16 18:00:34 UTC
Hi,

Can you test on kernel 4.16? It looks like lirc_zilog is gone in 4.16 and replaced with the ir-kbd-i2c driver. You can either install the F28 kernel[0] or use Copr to install the stablization kernel for F27[1].

Thanks!

[0] https://koji.fedoraproject.org/koji/buildinfo?buildID=1069581
[1] https://copr.fedorainfracloud.org/coprs/jforbes/kernel-stabilization/

Comment 9 Warren Sturm 2018-04-16 18:44:18 UTC
I have F28 Beta loaded on another partition and used it for testing. 4.16 requires a different lircd.conf.d entry for the ir xmit on the hvr1600 but it does work.

There should be some patches available soon from the media group for 4.14 and 4.15.  I did not try 4.13.16 where xmit works but rmmod OOPs as well. The OOPs goes back to 4.11 when you rmmod lirc_zilog.

Comment 10 Jeremy Cline 2018-04-16 19:14:24 UTC
Cool, thanks for testing that. 

Since Fedora 27 will be getting the 4.16 kernel in the next week or so and I don't believe there will be any more 4.15 builds, I think the best path forward here is to mark this as fixed by the 4.16 update.

Comment 11 Warren Sturm 2018-04-16 19:30:14 UTC
Fedora 26 is at 4.15.16 I think.

Here is a link for the DCT700 codes needed under 4.16

https://help.ubuntu.com/community/Motorola_DCT700_Channel_Change_Script

Comment 12 Fedora Update System 2018-04-20 00:08:03 UTC
kernel-4.16.3-200.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b6be90818d

Comment 13 Fedora Update System 2018-04-21 05:02:28 UTC
kernel-4.16.3-200.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b6be90818d

Comment 14 Warren Sturm 2018-04-22 19:28:45 UTC
I have tried out the 4.16.3 kernel and was able to get IR transmit working.  lircd is still needed as well as the new DCT700 codes from comment 11.  There will be adjustments to the lirc config files required.

Comment 15 Jeremy Cline 2018-04-24 21:54:56 UTC
Thanks for testing it out.

Comment 16 Fedora Update System 2018-04-26 13:10:29 UTC
kernel-4.16.4-100.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-884a105c04

Comment 17 Fedora Update System 2018-04-27 01:20:11 UTC
kernel-4.16.3-200.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2018-04-27 07:14:37 UTC
kernel-4.16.4-100.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-884a105c04

Comment 19 Fedora Update System 2018-04-28 16:15:49 UTC
kernel-4.16.5-100.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-884a105c04

Comment 20 Fedora Update System 2018-05-01 14:59:59 UTC
kernel-4.16.6-100.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-884a105c04

Comment 21 Fedora Update System 2018-05-02 09:51:56 UTC
kernel-4.16.6-100.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-884a105c04

Comment 22 Fedora Update System 2018-05-03 12:33:50 UTC
kernel-4.16.7-100.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-884a105c04

Comment 23 Fedora Update System 2018-05-06 05:34:11 UTC
kernel-4.16.7-100.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-884a105c04

Comment 24 Fedora Update System 2018-05-11 17:45:28 UTC
kernel-4.16.7-100.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.