Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1532140 - [RFE] Add NIC Mapping Reporting Feature
[RFE] Add NIC Mapping Reporting Feature
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-net-config (Show other bugs)
11.0 (Ocata)
x86_64 Linux
high Severity high
: z5
: 11.0 (Ocata)
Assigned To: zenghui.shi
Shai Revivo
: FutureFeature, RFE, Triaged, ZStream
: 1268421 (view as bug list)
Depends On: 1532102
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-08 02:07 EST by zenghui.shi
Modified: 2018-05-31 09:08 EDT (History)
11 users (show)

See Also:
Fixed In Version: os-net-config-6.1.2-2.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1532102
Environment:
Last Closed: 2018-05-18 13:08:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1622 None None None 2018-05-18 13:09 EDT

  None (edit)
Description zenghui.shi 2018-01-08 02:07:52 EST
+++ This bug was initially created as a clone of Bug #1532102 +++

Description of problem:

os-net-config reports NIC mapping, but only if you run in debug mode. Furthermore, the mapping output is not easily parsed for use in scripts. This is causing serious issues when troubleshooting or writing validations.

os-net-config should contain an option for returning the exact mapping, and it should return an easily consumable JSON or dict. For example, -i or --interfaces could return a mapping of the numeric NICs to real NIC name. This will make it possible to determine whether a mapping file is working correctly, or whether the desired mapped NICs are down (in which case they will not be mapped correctly).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from zenghui.shi on 2018-01-07 20:24:21 EST ---

upstream bug: https://bugs.launchpad.net/os-net-config/+bug/1713137

--- Additional comment from zenghui.shi on 2018-01-08 01:34:16 EST ---

targeting this for 10.z as this is a request to backport NIC mapping to 10.z.
Comment 1 zenghui.shi 2018-01-08 02:12:50 EST
this bz is to backport nic mapping to 11.z
Comment 7 errata-xmlrpc 2018-05-18 13:08:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1622
Comment 8 Bob Fournier 2018-05-31 09:08:51 EDT
*** Bug 1268421 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.