Bug 1532182 - Create serviceinstance via YAML will make overview page go wrong
Summary: Create serviceinstance via YAML will make overview page go wrong
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.7.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-08 10:04 UTC by shahan
Modified: 2018-04-05 09:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, provisioned services that reference service classes or service plans that do not exist would not display correctly in the web console overview. This problem has been fixed. The web console now shows provisioned services even when its referenced service class doesn't exist.
Clone Of:
Environment:
Last Closed: 2018-04-05 09:34:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:35:02 UTC

Description shahan 2018-01-08 10:04:56 UTC
Description of problem:
Create serviceinstance via YAML will make overview page go wrong

Version-Release number of selected component (if applicable):
     v3.9.0-0.15.0

How reproducible:
 Always

Steps to Reproduce:
1. Create **empty** project
2. create serviceinstance by 'Import YAML/JSON', could use this yaml file:
 https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/svc-catalog/serviceinstance-template.yaml (change the param INSTANCE_NAMESPACE to your project name)
3. check overview page and provisioned service page

Actual results:
3. overview page only show "The filter is hiding all resources. Clear Filter"
provisioned service page will see the created serviceinstance

Expected results:
3 Should also see the serviceinstance on overview page

Additional info:

Comment 1 Samuel Padgett 2018-01-08 13:41:42 UTC
I've fixed one problem in this PR:

https://github.com/openshift/origin-web-console/pull/2635

The instances were not showing up correctly when the corresponding service class did not exist. But the symptoms I saw were a little different: I didn't get the filter hiding everything message, but the normal empty state message.

In your environment, do you have the ansible service broker installed with this service class and service plan?

Comment 2 openshift-github-bot 2018-01-08 13:52:11 UTC
Commits pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/f913823d4668ef3fc9e82f8c17ca5f7701c31777
Bug 1532182 - Handle missing service class for instance

Avoid display problems on the overview when a service instance
references a non-existent service class or service plan.

https://github.com/openshift/origin-web-console/commit/733c230fde5b23e43e9235b579385e5157799cd2
Merge pull request #2635 from spadgett/missing-service-class

Automatic merge from submit-queue.

Bug 1532182 - Handle missing service class for instance

Avoid display problems on the overview when a service instance
references a non-existent service class or service plan.

/kind bug
/assign @jwforres

Comment 3 Samuel Padgett 2018-01-08 16:00:38 UTC
3.7 fix for missing service class reference:

https://github.com/openshift/origin-web-console/pull/2636

Comment 4 Samuel Padgett 2018-01-08 16:10:05 UTC
Adding need info flag for this question:

In your environment, do you have the ansible service broker installed with this service class and service plan?

Comment 5 shahan 2018-01-09 01:58:18 UTC
Just a standalone serviceinstance created by that mentioned yaml file, non-existent service class or service plan for it.

Comment 7 shahan 2018-01-26 06:24:45 UTC
Checked this issue in OCP v3.9.0-0.24.0, could create via YAML file successfully.

Comment 11 errata-xmlrpc 2018-04-05 09:34:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.