Bug 1532251 - Can't install the odl-netvirt-openstack feature due to a problem in the leveldbjni jar
Summary: Can't install the odl-netvirt-openstack feature due to a problem in the level...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: leveldbjni
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Stephen Kitt
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-08 13:37 UTC by Mike Kolesnik
Modified: 2018-10-18 07:25 UTC (History)
0 users

Fixed In Version: leveldbjni-1.8-15.7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2018-06-27 13:40:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:41:41 UTC

Description Mike Kolesnik 2018-01-08 13:37:04 UTC
Description of problem:
Running feature:install odl-netvirt-openstack throws an error, which can be boiled down to:

opendaylight-user@root>feature:install odl-akka-leveldb-0.7
Error executing command: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=odl-akka-leveldb-0.7; type=karaf.feature; version="[2.0.5.redhat-1,2.0.5.redhat-1]"; filter:="(&(osgi.identity=odl-akka-leveldb-0.7)(type=karaf.feature)(version>=2.0.5.redhat-1)(version<=2.0.5.redhat-1))" [caused by: Unable to resolve odl-akka-leveldb-0.7/2.0.5.redhat-1: missing requirement [odl-akka-leveldb-0.7/2.0.5.redhat-1] osgi.identity; osgi.identity=org.fusesource.leveldbjni.leveldbjni-all; type=osgi.bundle; version="[1.8.0,1.8.0]"; resolution:=mandatory [caused by: Unable to resolve org.fusesource.leveldbjni.leveldbjni-all/1.8.0: missing requirement [org.fusesource.leveldbjni.leveldbjni-all/1.8.0] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.iq80.leveldb)(version>=1.8.0)(!(version>=2.0.0)))"]]




Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1. Install opendaylight from brew https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14888790
2. Run feature:install odl-netvirt-openstack
3.

Actual results:
Error executing command: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=odl-netvirt-openstack; type=karaf.feature; version="[0.5.2.redhat-1,0.5.2.redhat-1]"; filter:="(&(osgi.identity=odl-netvirt-openstack)(type=karaf.feature)(version>=0.5.2.redhat-1)(version<=0.5.2.redhat-1))" [caused by: Unable to resolve odl-netvirt-openstack/0.5.2.redhat-1: missing requirement [odl-netvirt-openstack/0.5.2.redhat-1] osgi.identity; osgi.identity=odl-netvirt-impl; type=karaf.feature; version="[0.5.2.redhat-1,0.5.2.redhat-1]" [caused by: Unable to resolve odl-netvirt-impl/0.5.2.redhat-1: missing requirement [odl-netvirt-impl/0.5.2.redhat-1] osgi.identity; osgi.identity=odl-openflowplugin-flow-services; type=karaf.feature; version="[0.5.2.redhat-1,0.5.2.redhat-1]" [caused by: Unable to resolve odl-openflowplugin-flow-services/0.5.2.redhat-1: missing requirement [odl-openflowplugin-flow-services/0.5.2.redhat-1] osgi.identity; osgi.identity=odl-openflowplugin-app-forwardingrules-manager; type=karaf.feature; version="[0.5.2.redhat-1,0.5.2.redhat-1]" [caused by: Unable to resolve odl-openflowplugin-app-forwardingrules-manager/0.5.2.redhat-1: missing requirement [odl-openflowplugin-app-forwardingrules-manager/0.5.2.redhat-1] osgi.identity; osgi.identity=odl-openflowplugin-southbound; type=karaf.feature; version="[0.5.2.redhat-1,0.5.2.redhat-1]" [caused by: Unable to resolve odl-openflowplugin-southbound/0.5.2.redhat-1: missing requirement [odl-openflowplugin-southbound/0.5.2.redhat-1] osgi.identity; osgi.identity=odl-mdsal-broker; type=karaf.feature; version="[1.6.2.redhat-1,1.6.2.redhat-1]" [caused by: Unable to resolve odl-mdsal-broker/1.6.2.redhat-1: missing requirement [odl-mdsal-broker/1.6.2.redhat-1] osgi.identity; osgi.identity=odl-mdsal-remoterpc-connector; type=karaf.feature; version="[1.6.2.redhat-1,1.6.2.redhat-1]" [caused by: Unable to resolve odl-mdsal-remoterpc-connector/1.6.2.redhat-1: missing requirement [odl-mdsal-remoterpc-connector/1.6.2.redhat-1] osgi.identity; osgi.identity=odl-akka-leveldb-0.7; type=karaf.feature; version="[2.0.5.redhat-1,2.0.5.redhat-1]" [caused by: Unable to resolve odl-akka-leveldb-0.7/2.0.5.redhat-1: missing requirement [odl-akka-leveldb-0.7/2.0.5.redhat-1] osgi.identity; osgi.identity=org.fusesource.leveldbjni.leveldbjni-all; type=osgi.bundle; version="[1.8.0,1.8.0]"; resolution:=mandatory [caused by: Unable to resolve org.fusesource.leveldbjni.leveldbjni-all/1.8.0: missing requirement [org.fusesource.leveldbjni.leveldbjni-all/1.8.0] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.iq80.leveldb)(version>=1.8.0)(!(version>=2.0.0)))"]]]]]]]]]



Expected results:
The feature should be installed without errors


Additional info:
Something fishy with the MANIFEST.MF file, maybe it has an invalid Import-Package

Comment 4 Stephen Kitt 2018-01-11 10:51:52 UTC
The build has been purged, I’ve started a new one on https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14919197

Comment 5 Stephen Kitt 2018-01-24 08:55:31 UTC
I was hoping https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=15083068 would have fixed this, but it didn’t. The Brew builds result in

Import-Package: org.iq80.leveldb;version="[1.8,2)"
Tool: Bnd-1.50.0

whereas a local (working) build results in

Import-Package: org.iq80.leveldb;version="[0.6,1)"
Tool: Bnd-3.3.0

I’m hoping we can convince the older Bnd to produce the correct Import-Package statement...

Comment 6 Stephen Kitt 2018-01-24 16:51:23 UTC
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=15089384 fixes this.

Comment 11 Itzik Brown 2018-03-18 13:28:47 UTC
Checked with opendaylight-8.0.0-2.el7ost.noarch.rpm 

karaf@root()> feature:list |grep openstack
odl-netvirt-openstack                           | 0.6.0.redhat-2   | x        | Started     | odl-netvirt-openstack                           | OpenDaylight :: NetVirt :: OpenStack

Comment 13 errata-xmlrpc 2018-06-27 13:40:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.